aboutsummaryrefslogtreecommitdiff
path: root/astro/celestia/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'astro/celestia/Makefile')
-rw-r--r--astro/celestia/Makefile14
1 files changed, 7 insertions, 7 deletions
diff --git a/astro/celestia/Makefile b/astro/celestia/Makefile
index e62cec3d3c48..1dbc884f9d18 100644
--- a/astro/celestia/Makefile
+++ b/astro/celestia/Makefile
@@ -1,20 +1,21 @@
-# Created by: trevor
-
PORTNAME= celestia
PORTVERSION= 1.6.1
-PORTREVISION= 13
+PORTREVISION= 14
CATEGORIES= astro
MASTER_SITES= SF/${PORTNAME}/Celestia-source/${PORTVERSION}
PKGNAMESUFFIX= -${CELESTIA_UI}
MAINTAINER= danfe@FreeBSD.org
COMMENT= Scriptable space flight simulator for X11
+WWW= https://celestia.space
LICENSE= GPLv2
LIB_DEPENDS= libpng.so:graphics/png
-USES= compiler:c++11-lang gettext gl gmake jpeg libtool lua:52 pkgconfig
+USES= compiler:c++11-lang gettext gl gmake jpeg libtool localbase:ldflags \
+ lua:52 pkgconfig
+USE_CXXSTD= c++14
USE_GL= gl
GNU_CONFIGURE= yes
EXTRA_PATCHES= ${FILESDIR}/celestia-1.6.1-lua-5.2.patch:-p1 \
@@ -23,12 +24,11 @@ EXTRA_PATCHES= ${FILESDIR}/celestia-1.6.1-lua-5.2.patch:-p1 \
${FILESDIR}/celestia-1.6.1-gcc48.patch:-p1
CXXFLAGS+= -fsigned-char # fix text rendering (see Gentoo bug 316573)
-CPPFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib -pthread
+LDFLAGS+= -pthread
UI_LIST= glut gtk gnome
CELESTIA_UI?= glut
-CONFLICTS= ${UI_LIST:S|${CELESTIA_UI}||:S|^|celestia-|:S|$|-[0-9]*|}
+CONFLICTS_INSTALL= ${UI_LIST:S|^|celestia-|}
# Celestia provides different UI frontends; you should pick one that suits
# you best by setting CELESTIA_UI variable. Possible values are: