aboutsummaryrefslogtreecommitdiff
path: root/astro/josm/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'astro/josm/Makefile')
-rw-r--r--astro/josm/Makefile18
1 files changed, 5 insertions, 13 deletions
diff --git a/astro/josm/Makefile b/astro/josm/Makefile
index 53a40b087f6a..7a43d8be3eb9 100644
--- a/astro/josm/Makefile
+++ b/astro/josm/Makefile
@@ -1,15 +1,13 @@
-# Created by: Gleb Smirnoff <glebius@FreeBSD.org>
-
PORTNAME= josm
-PORTVERSION= 18193
+PORTVERSION= 19039
CATEGORIES= astro java
-MASTER_SITES= https://josm.openstreetmap.de/download/ \
- https://mirror.amdmi3.ru/distfiles/
+MASTER_SITES= https://josm.openstreetmap.de/download/
DISTNAME= ${PORTNAME}-snapshot-${PORTVERSION}.jar
EXTRACT_SUFX= # empty
MAINTAINER= amdmi3@FreeBSD.org
COMMENT= Comprehensive editor for OpenStreetMap.org database
+WWW= https://josm.openstreetmap.de/
LICENSE= GPLv2+
@@ -19,15 +17,13 @@ NO_WRKSUBDIR= yes
USES= zip:infozip
USE_JAVA= yes
-JAVA_VERSION= 1.8+
-
-JOSM_MEMORY_LIMIT?=1024
+JAVA_VERSION= 8+
NO_BUILD= yes
NO_ARCH= yes
SUB_FILES= josm.sh
-SUB_LIST= JARNAME=${DISTNAME} JOSM_MEMORY_LIMIT=${JOSM_MEMORY_LIMIT}
+SUB_LIST= JARNAME=${DISTNAME}
PLIST_FILES= bin/josm \
${JAVAJARDIR:C,${PREFIX}/?,,}/${DISTNAME} \
@@ -40,10 +36,6 @@ DESKTOP_ENTRIES="JOSM" \
"Education;Geoscience;Maps;" \
true
-pre-everything::
- @${ECHO_CMD} "You can change limit of memory available to josm by defining"
- @${ECHO_CMD} "JOSM_MEMORY_LIMIT variable in /etc/make.conf. Default is 1024 (MB)."
-
do-install:
@${MKDIR} ${STAGEDIR}${JAVAJARDIR}/
${INSTALL_DATA} ${DISTDIR}/${DISTNAME} ${STAGEDIR}${JAVAJARDIR}/