aboutsummaryrefslogtreecommitdiff
path: root/astro/mepo/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'astro/mepo/Makefile')
-rw-r--r--astro/mepo/Makefile6
1 files changed, 5 insertions, 1 deletions
diff --git a/astro/mepo/Makefile b/astro/mepo/Makefile
index b35f28c11a8a..e273a2e96d36 100644
--- a/astro/mepo/Makefile
+++ b/astro/mepo/Makefile
@@ -1,6 +1,6 @@
PORTNAME= mepo
DISTVERSION= 1.1.1
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= astro geography wayland
MASTER_SITES= https://git.sr.ht/~mil/${PORTNAME}/archive/${DISTVERSIONFULL}${EXTRACT_SUFX}?dummy=/
@@ -41,6 +41,10 @@ post-patch:
do-build:
@(cd ${WRKSRC} && ${MAKE_ENV} zig build ${CONFIGURE_ARGS})
+post-install:
+ @${STAGEDIR}${PREFIX}/bin/${PORTNAME} -docman \
+ >${STAGEDIR}${PREFIX}/share/man/man1/${PORTNAME}.1
+
do-test:
@(cd ${WRKSRC} && ${TEST_ENV} zig build test ${CONFIGURE_ARGS})