aboutsummaryrefslogtreecommitdiff
path: root/astro/merkaartor/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'astro/merkaartor/Makefile')
-rw-r--r--astro/merkaartor/Makefile13
1 files changed, 6 insertions, 7 deletions
diff --git a/astro/merkaartor/Makefile b/astro/merkaartor/Makefile
index 8aca54c4089c..c403b700e535 100644
--- a/astro/merkaartor/Makefile
+++ b/astro/merkaartor/Makefile
@@ -1,19 +1,18 @@
-# Created by: Slaven Rezic <slaven@rezic.de>
-
PORTNAME= merkaartor
PORTVERSION= 0.19.0
-PORTREVISION= 4
+PORTREVISION= 18
CATEGORIES= astro
MAINTAINER= dev2@heesakkers.info
COMMENT= Openstreetmap mapping program
+WWW= http://merkaartor.be/
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/LICENSE
LIB_DEPENDS= libgdal.so:graphics/gdal \
libproj.so:graphics/proj \
- libquazip1-qt5.so:archivers/quazip
+ libquazip1-qt5.so:archivers/quazip@qt5
USES= compiler:c++11-lang gnome pkgconfig qmake qt:5 sqlite:3
USE_GITHUB= yes
@@ -21,9 +20,9 @@ GH_ACCOUNT= openstreetmap
USE_LDCONFIG= yes
QMAKE_ARGS= SYSTEM_QUAZIP=1
-USE_QT= buildtools_build \
+USE_QT= buildtools:build \
concurrent core gui imageformats network printsupport svg \
- webkit widgets xml
+ webengine widgets xml
OPTIONS_DEFINE= DEBUG GEOIMAGE NLS PROTOBUF ZBAR
OPTIONS_DEFAULT= GEOIMAGE
@@ -45,7 +44,7 @@ ZBAR_BROKEN= Does not build with option ZBAR selected
DEBUG_QMAKE_OFF= NODEBUG=1 RELEASE=1
NLS_USES= qt:5
-NLS_USE= QT=linguisttools_build
+NLS_USE= QT=linguisttools:build
OPTIONS_SUB= yes