aboutsummaryrefslogtreecommitdiff
path: root/astro/phd2/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'astro/phd2/Makefile')
-rw-r--r--astro/phd2/Makefile8
1 files changed, 6 insertions, 2 deletions
diff --git a/astro/phd2/Makefile b/astro/phd2/Makefile
index 39a438fafed4..a5413ccac55c 100644
--- a/astro/phd2/Makefile
+++ b/astro/phd2/Makefile
@@ -1,10 +1,12 @@
PORTNAME= phd2
DISTVERSIONPREFIX=v
DISTVERSION= 2.6.10
+PORTREVISION= 9
CATEGORIES= astro
MAINTAINER= acm@FreeBSD.org
COMMENT= Guiding software inspired by Stark Labs PHD Guiding
+WWW= https://openphdguiding.org/
LICENSE= BSD3CLAUSE
@@ -19,7 +21,8 @@ USES= cmake eigen:3 gettext ninja pkgconfig xorg
USE_GITHUB= yes
GH_ACCOUNT= OpenPHDGuiding
-USE_WX= 3.1+
+USE_CXXSTD= c++14 # googletest 1.13
+USE_WX= 3.2+
USE_XORG= x11
WX_COMPS= wx
@@ -28,7 +31,8 @@ CMAKE_ARGS+= -DUSE_SYSTEM_GTEST:BOOL=YES \
-DUSE_SYSTEM_CFITSIO:BOOL=YES \
-DUSE_SYSTEM_LIBUSB:BOOL=YES \
-DUSE_SYSTEM_LIBINDI:BOOL=YES \
- -DUSE_SYSTEM_EIGEN3:BOOL=YES
+ -DUSE_SYSTEM_EIGEN3:BOOL=YES \
+ -DwxWidgets_CONFIG_EXECUTABLE=${LOCALBASE}/bin/wxgtk3u-3.2-config
.include <bsd.port.options.mk>