aboutsummaryrefslogtreecommitdiff
path: root/astro/py-astLib/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'astro/py-astLib/Makefile')
-rw-r--r--astro/py-astLib/Makefile10
1 files changed, 5 insertions, 5 deletions
diff --git a/astro/py-astLib/Makefile b/astro/py-astLib/Makefile
index ff33bdd0602b..beaaed8dd727 100644
--- a/astro/py-astLib/Makefile
+++ b/astro/py-astLib/Makefile
@@ -14,15 +14,15 @@ LICENSE= LGPL21
LICENSE_FILE= ${WRKSRC}/LICENSE
BUILD_DEPENDS= ${PYNUMPY} \
- ${PKGNAMEPREFIX}scipy>=0.7.0:science/py-scipy \
- ${PKGNAMEPREFIX}pillow>0:graphics/py-pillow \
- ${PKGNAMEPREFIX}pyfits>=1.1:astro/py-pyfits \
- ${PKGNAMEPREFIX}matplotlib>=0.98:math/py-matplotlib
+ ${PKGNAMEPREFIX}scipy>=0.7.0:science/py-scipy@${FLAVOR} \
+ ${PKGNAMEPREFIX}pillow>0:graphics/py-pillow@${FLAVOR} \
+ ${PKGNAMEPREFIX}pyfits>=1.1:astro/py-pyfits@${FLAVOR} \
+ ${PKGNAMEPREFIX}matplotlib>=0.98:math/py-matplotlib@${FLAVOR}
RUN_DEPENDS:= ${BUILD_DEPENDS}
PORTSCOUT= skipv:0.15,0.17,0.17.1 # incorrect versioning upstream
-USES= python
+USES= python:2.7
USE_PYTHON= autoplist distutils
post-install: