aboutsummaryrefslogtreecommitdiff
path: root/astro/xtide/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'astro/xtide/Makefile')
-rw-r--r--astro/xtide/Makefile6
1 files changed, 5 insertions, 1 deletions
diff --git a/astro/xtide/Makefile b/astro/xtide/Makefile
index 6e8d64c3335a..9cad1ed479ec 100644
--- a/astro/xtide/Makefile
+++ b/astro/xtide/Makefile
@@ -1,5 +1,6 @@
PORTNAME= xtide
PORTVERSION= 2.15.5
+PORTREVISION= 2
CATEGORIES= astro geography
MASTER_SITES= https://flaterco.com/files/xtide/
DISTFILES= ${DISTNAME}${EXTRACT_SUFX} \
@@ -8,6 +9,7 @@ DISTFILES= ${DISTNAME}${EXTRACT_SUFX} \
MAINTAINER= wen@FreeBSD.org
COMMENT= Harmonic tide clock and tide predictor
+WWW= https://flaterco.com/xtide/
LICENSE= GPLv3
LICENSE_FILE= ${WRKSRC}/COPYING
@@ -15,9 +17,11 @@ LICENSE_FILE= ${WRKSRC}/COPYING
LIB_DEPENDS= libpng.so:graphics/png
USES= compiler:c++0x gmake libtool localbase tar:xz
+USE_CXXSTD= c++11
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
+GNU_CONFIGURE_MANPREFIX=${PREFIX}/share
CONFIGURE_ENV= ac_cv_header_tcd_h=yes \
ac_cv_lib_tcd_get_tide_db_header=yes
CFLAGS+= -Wno-deprecated-declarations
@@ -38,7 +42,7 @@ X11_DESKTOP_ENTRIES= "XTide" "" "xtide" "xtide" "" ""
DISTNAME_TCD= libtcd-2.2.7-r3
WRKSRC_TCD= ${WRKDIR}/${DISTNAME_TCD:C/-r[0-9]+//}
-DISTNAME_HARM= harmonics-dwf-20210110-free
+DISTNAME_HARM= harmonics-dwf-20240104-free
WRKSRC_HARM= ${WRKDIR}/${DISTNAME_HARM:C/-free//}
DISTNAME_WVS= wvs