aboutsummaryrefslogtreecommitdiff
path: root/audio/calf-lv2/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'audio/calf-lv2/Makefile')
-rw-r--r--audio/calf-lv2/Makefile17
1 files changed, 8 insertions, 9 deletions
diff --git a/audio/calf-lv2/Makefile b/audio/calf-lv2/Makefile
index b91b9d375e5b..e7d3a3676a35 100644
--- a/audio/calf-lv2/Makefile
+++ b/audio/calf-lv2/Makefile
@@ -1,13 +1,13 @@
-# Created by: <trasz@FreeBSD.org>
-
PORTNAME= calf
DISTVERSION= 0.90.3.20210427
+PORTREVISION= 3
CATEGORIES= audio
#MASTER_SITES= http://calf-studio-gear.org/files/
PKGNAMESUFFIX= -lv2
MAINTAINER= yuri@FreeBSD.org
-COMMENT= Set of LV2 plugins
+COMMENT= Calf Studio Gear: audio plug-in pack for LV2 and JACK
+WWW= https://calf-studio-gear.org/
LICENSE= GPLv2 LGPL21
LICENSE_COMB= multi
@@ -20,12 +20,13 @@ LIB_DEPENDS= libfluidsynth.so:audio/fluidsynth \
libjack.so:audio/jack \
libexpat.so:textproc/expat2
-USES= autoreconf gmake gnome libtool localbase pkgconfig
+USES= autoreconf desktop-file-utils gmake gnome libtool localbase pkgconfig
USE_GNOME= cairo gdkpixbuf2 gtk20
USE_CXXSTD= c++11
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
+GNU_CONFIGURE_MANPREFIX= ${PREFIX}/share
CONFIGURE_ARGS= --with-lv2 --disable-static
USE_GITHUB= yes
@@ -49,20 +50,18 @@ SSE_CONFIGURE_ENABLE= sse
PORTDOCS= *
+PORTSCOUT= limit:^[0-9\.]*$$ # prevet tags like 'works'
+
.include <bsd.port.options.mk>
.if ${ARCH} == powerpc64le
USES+= compiler:gcc-c++11-lib
.else
-USES+= compiler:c++11-lang
+USES+= compiler:c++11-lang
.endif
.include <bsd.port.pre.mk>
-.if ${CHOSEN_COMPILER_TYPE} == gcc
-CXXFLAGS+= -finline-limit=80 -finline-functions -finline-functions-called-once
-.endif
-
post-install: # fix absolute symbolic link to be relative
@${RM} ${STAGEDIR}${PREFIX}/lib/lv2/calf.lv2/calf.so
@${RLN} ${STAGEDIR}${PREFIX}/lib/calf/libcalf.so ${STAGEDIR}${PREFIX}/lib/lv2/calf.lv2/calf.so