aboutsummaryrefslogtreecommitdiff
path: root/audio/denemo/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'audio/denemo/Makefile')
-rw-r--r--audio/denemo/Makefile28
1 files changed, 16 insertions, 12 deletions
diff --git a/audio/denemo/Makefile b/audio/denemo/Makefile
index 3ef8ab0b70c1..48d34d2a90bc 100644
--- a/audio/denemo/Makefile
+++ b/audio/denemo/Makefile
@@ -1,18 +1,15 @@
-# Created by: trevor
-
PORTNAME= denemo
PORTVERSION= 2.0.6
-PORTREVISION= 10
+PORTREVISION= 18
CATEGORIES= audio
MASTER_SITES= GNU
MAINTAINER= multimedia@FreeBSD.org
COMMENT= Graphical score editor
+WWW= http://www.denemo.org/
LICENSE= GPLv3+
-BROKEN_armv6= fails to package: tar: Pathname cannot be converted from UTF-8 to current locale
-BROKEN_armv7= fails to package: tar: Pathname cannot be converted from UTF-8 to current locale
BROKEN_mips= fails to package: tar: Pathname cannot be converted from UTF-8 to current locale
LIB_DEPENDS= libaubio.so:audio/aubio \
@@ -22,7 +19,10 @@ LIB_DEPENDS= libaubio.so:audio/aubio \
libsndfile.so:audio/libsndfile \
libportaudio.so:audio/portaudio \
librubberband.so:audio/rubberband \
- libguile.so:lang/guile1 \
+ libharfbuzz.so:print/harfbuzz \
+ libfontconfig.so:x11-fonts/fontconfig \
+ libfreetype.so:print/freetype2 \
+ libsamplerate.so:audio/libsamplerate \
libfftw3.so:math/fftw3
RUN_DEPENDS= xdg-open:devel/xdg-utils
@@ -30,8 +30,8 @@ EXTRACT_BEFORE_ARGS=\
-s '!\(/Clarinet in B\).*\(\.denemo\)$$!\1b\2!p' -xf
USES= bison:alias compiler:c++11-lang desktop-file-utils gettext gmake \
- gnome pkgconfig
-USE_GNOME= intltool librsvg2 libxml2
+ gnome guile:1.8 localbase:ldflags pkgconfig
+USE_GNOME= cairo intltool librsvg2 libxml2
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --enable-jack \
--disable-alsa \
@@ -42,8 +42,6 @@ CONFIGURE_ARGS= --enable-jack \
--enable-guile_1_8
CFLAGS+= -Wno-error=return-type
-CPPFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib
OPTIONS_DEFINE= DOCS EXAMPLES LILYPOND PDF
OPTIONS_SINGLE= TOOLKIT
@@ -56,7 +54,7 @@ GTK3_USE= gnome=gtk30,gtksourceview3
LILYPOND_DESC= Install LilyPond (Printing)
LILYPOND_RUN_DEPENDS= lilypond:print/lilypond
PDF_CONFIGURE_OFF= --disable-evince
-TOOLKIT_DESC= GTK+ toolkit
+TOOLKIT_DESC= GTK toolkit
.include <bsd.port.options.mk>
@@ -68,6 +66,12 @@ LIB_DEPENDS+= libevview3.so:graphics/evince
LIB_DEPENDS+= libatrilview.so:graphics/atril
.endif
+.include <bsd.port.pre.mk>
+
+.if ${COMPILER_TYPE} == clang && ${COMPILER_VERSION} >= 160
+CFLAGS+= -Wno-error=incompatible-function-pointer-types
+.endif
+
post-patch:
@${REINPLACE_CMD} -e \
's|-lpthread|-pthread| ; \
@@ -106,4 +110,4 @@ post-install-EXAMPLES-on:
(cd ${WRKSRC}/examples && ${INSTALL_DATA} *.denemo \
${STAGEDIR}${EXAMPLESDIR})
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>