aboutsummaryrefslogtreecommitdiff
path: root/audio/dmidiplayer/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'audio/dmidiplayer/Makefile')
-rw-r--r--audio/dmidiplayer/Makefile11
1 files changed, 7 insertions, 4 deletions
diff --git a/audio/dmidiplayer/Makefile b/audio/dmidiplayer/Makefile
index 0a3ff9845dc5..57304d872bc5 100644
--- a/audio/dmidiplayer/Makefile
+++ b/audio/dmidiplayer/Makefile
@@ -1,20 +1,23 @@
PORTNAME= dmidiplayer
-DISTVERSION= 1.6.0
+DISTVERSION= 1.7.3
CATEGORIES= audio
MASTER_SITES= SF/${PORTNAME}/v${DISTVERSION}/
MAINTAINER= yuri@FreeBSD.org
COMMENT= Featured MIDI file player
+WWW= https://sourceforge.net/projects/dmidiplayer/
LICENSE= GPLv3
LICENSE_FILE= ${WRKSRC}/LICENSE
-LIB_DEPENDS= libdrumstick-rt.so:audio/drumstick \
+LIB_DEPENDS= libdrumstick-widgets.so:audio/drumstick \
+ libOpenGL.so:graphics/libglvnd \
libuchardet.so:textproc/uchardet
-USES= compiler:c++11-lang cmake desktop-file-utils pkgconfig qt:5 tar:bz2
-USE_QT= core gui printsupport widgets buildtools_build linguisttools qmake_build
+USES= compiler:c++17-lang cmake desktop-file-utils pkgconfig qt:6 tar:bz2
+USE_QT= base 5compat tools:build
+CMAKE_ARGS= -DUSE_QT=6
CMAKE_ON= EMBED_TRANSLATIONS
CMAKE_OFF= BUILD_DOCS