aboutsummaryrefslogtreecommitdiff
path: root/audio/dumb/files/patch-Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'audio/dumb/files/patch-Makefile')
-rw-r--r--audio/dumb/files/patch-Makefile57
1 files changed, 0 insertions, 57 deletions
diff --git a/audio/dumb/files/patch-Makefile b/audio/dumb/files/patch-Makefile
deleted file mode 100644
index 623e96378a90..000000000000
--- a/audio/dumb/files/patch-Makefile
+++ /dev/null
@@ -1,57 +0,0 @@
---- ./Makefile.orig Mon Aug 8 02:18:41 2005
-+++ ./Makefile Sun Jun 10 12:13:59 2007
-@@ -22,7 +22,7 @@
- # (Note that this is unable to delete the dumbask
- # executable if the configuration is absent.)
-
--MAKEFILE = Makefile.rdy
-+MAKEFILE = Makefile
-
- .PHONY: all install uninstall clean veryclean distclean config config-if-necessary make-outdirs
-
-@@ -36,12 +36,12 @@
- COMMA := ,
-
- ifdef USE_ICC
--CC := icc
-+CC ?= icc
- else
- ifdef USE_SGICC
--CC := cc
-+CC ?= cc
- else
--CC := gcc
-+CC ?= gcc
- endif
- endif
- AR := ar
-@@ -215,24 +215,21 @@
- ifdef USE_ICC
- WFLAGS := -Wall -DDUMB_DECLARE_DEPRECATED
- WFLAGS_ALLEGRO :=
--OFLAGS := -O2
--DBGFLAGS := -DDEBUGMODE=1
-+OFLAGS=$(CFLAGS)
- else
- ifdef USE_SGICC
- WFLAGS := -fullwarn -DDUMB_DECLARE_DEPRECATED
- WFLAGS_ALLEGRO :=
--OFLAGS := -n32 -O2 -use_readonly_const
--DBGFLAGS := -n32 -g3 -DDEBUGMODE=1
-+OFLAGS=$(CFLAGS)
- else
- WFLAGS := -Wall -W -Wwrite-strings -Wstrict-prototypes -Wmissing-declarations -DDUMB_DECLARE_DEPRECATED
- WFLAGS_ALLEGRO := -Wno-missing-declarations
--OFLAGS := -O2 -ffast-math -fomit-frame-pointer
--DBGFLAGS := -DDEBUGMODE=1 -g3
-+OFLAGS=$(CFLAGS)
- endif
- endif
-
--CFLAGS_RELEASE := -Iinclude $(WFLAGS) $(OFLAGS)
--CFLAGS_DEBUG := -Iinclude $(WFLAGS) $(DBGFLAGS)
-+CFLAGS_RELEASE := -Iinclude -I$(PREFIX)/include $(_PORT_ALLEGRO_CFLAGS) $(WFLAGS) $(OFLAGS)
-+CFLAGS_DEBUG := -Iinclude -I$(PREFIX)/include $(_PORT_ALLEGRO_CFLAGS) $(WFLAGS) $(DBGFLAGS)
-
- LDFLAGS := -s
-