aboutsummaryrefslogtreecommitdiff
path: root/audio/faust-lv2/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'audio/faust-lv2/Makefile')
-rw-r--r--audio/faust-lv2/Makefile16
1 files changed, 8 insertions, 8 deletions
diff --git a/audio/faust-lv2/Makefile b/audio/faust-lv2/Makefile
index 9a9c06a53721..9d0560c8b9b3 100644
--- a/audio/faust-lv2/Makefile
+++ b/audio/faust-lv2/Makefile
@@ -1,12 +1,12 @@
PORTNAME= faust
-DISTVERSION= 1.4.20180118
-PORTREVISION= 6
+DISTVERSION= 1.4.20220802
CATEGORIES= audio
MASTER_SITES= https://bitbucket.org/${BB_ACCOUNT}/${BB_PROJECT}/get/${BB_COMMIT}.tar.gz?dummy=/
PKGNAMESUFFIX= -lv2
MAINTAINER= yuri@FreeBSD.org
COMMENT= LV2 plugin architecture for the Faust programming language
+WWW= https://bitbucket.org/agraef/faust-lv2
LICENSE= GPLv3
LICENSE_FILE= ${WRKSRC}/COPYING
@@ -15,6 +15,7 @@ BROKEN_aarch64= fails to link: can't create dynamic relocation R_AARCH64_ADR_PR
.if ${/usr/bin/ld:L:tA} == /usr/bin/ld.lld
BROKEN_i386= ld: error: can't create dynamic relocation R_386_32 against symbol: vtable for LV2UI in readonly segment
.endif
+BROKEN_riscv64= can't create dynamic relocation R_RISCV_LO12_I against symbol: vtable for LV2UI in readonly segment; recompile object files with -fPIC or pass '-Wl,-z,notext' to allow text relocations in the output
BUILD_DEPENDS= lv2>0:audio/lv2 \
faust>0:audio/faust \
@@ -24,15 +25,11 @@ USES= gmake localbase tar:bz2
BB_ACCOUNT= agraef
BB_PROJECT= faust-lv2
-BB_COMMIT= 4dc83e28e998
+BB_COMMIT= 27ed7cb9cb49
WRKSRC= ${WRKDIR}/${BB_ACCOUNT}-${BB_PROJECT}-${BB_COMMIT}
-CFLAGS_armv7= -fPIC
-CFLAGS_powerpc= -fPIC
-CFLAGS_powerpc64= -fPIC
-CFLAGS_powerpc64le= -fPIC
-LDFLAGS+= -fPIC # recommended by 13i386 failure messages, it was only failing
+CFLAGS+= -fPIC
OPTIONS_DEFINE_amd64= SIMD
OPTIONS_DEFINE_i386= SIMD
@@ -41,4 +38,7 @@ OPTIONS_DEFAULT_i386= SIMD
SIMD_CFLAGS= -msse -msse2 -mfpmath=sse
+post-install:
+ @${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/lv2/faust.lv2/*.so
+
.include <bsd.port.mk>