aboutsummaryrefslogtreecommitdiff
path: root/audio/faustlive/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'audio/faustlive/Makefile')
-rw-r--r--audio/faustlive/Makefile16
1 files changed, 8 insertions, 8 deletions
diff --git a/audio/faustlive/Makefile b/audio/faustlive/Makefile
index 5121901923e8..4588e805a428 100644
--- a/audio/faustlive/Makefile
+++ b/audio/faustlive/Makefile
@@ -1,16 +1,18 @@
PORTNAME= faustlive
-DISTVERSION= 2.5.11
+DISTVERSION= 2.5.18
+#MASTER_SITES= https://github.com/grame-cncm/faustlive/releases/download/${DISTVERSION}/
+#DISTFILES= FaustLive-${DISTVERSION}${EXTRACT_SUFX}
CATEGORIES= audio
MAINTAINER= yuri@FreeBSD.org
COMMENT= Standalone application that embeds Faust
+WWW= https://github.com/grame-cncm/faustlive
LICENSE= GPLv3
LICENSE_FILE= ${WRKSRC}/GPL.txt
BUILD_DEPENDS= bash:shells/bash
-LIB_DEPENDS= libLLVM-${LLVM_VERSION}.so:devel/llvm${LLVM_VERSION} \
- libasound.so:audio/alsa-lib \
+LIB_DEPENDS= libasound.so:audio/alsa-lib \
libcurl.so:ftp/curl \
libfaust.so:audio/faust \
libjack.so:audio/jack \
@@ -18,18 +20,16 @@ LIB_DEPENDS= libLLVM-${LLVM_VERSION}.so:devel/llvm${LLVM_VERSION} \
libqrencode.so:graphics/libqrencode \
libsndfile.so:audio/libsndfile # audio/alsa-lib isn't really needed: https://github.com/grame-cncm/faustlive/issues/3
-USES= compiler:c++11-lang gl pkgconfig qmake qt:5 shebangfix
-USE_QT= core gui network widgets buildtools_build
+USES= compiler:c++11-lang desktop-file-utils gl llvm:min=13,lib ncurses pkgconfig qmake qt:5 shebangfix # llvm version should be the same as in audio/faust
+USE_QT= core gui network widgets buildtools:build
USE_GL= gl
USE_GITHUB= yes
GH_ACCOUNT= grame-cncm
-GH_TUPLE= grame-cncm:faustlibraries:1b09fde:grame_cncm_faustlibraries/Resources/Libs
+GH_TUPLE= grame-cncm:faustlibraries:bbbb1be:grame_cncm_faustlibraries/Resources/Libs
SHEBANG_GLOB= build install makelibs
-LLVM_VERSION= 11 # llvm version should be the same as in audio/faust
-
QMAKE_ARGS= Build/FaustLive.pro
CXXFLAGS+= $$(llvm-config${LLVM_VERSION} --cflags)