aboutsummaryrefslogtreecommitdiff
path: root/audio/gmsynth-lv2/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'audio/gmsynth-lv2/Makefile')
-rw-r--r--audio/gmsynth-lv2/Makefile10
1 files changed, 7 insertions, 3 deletions
diff --git a/audio/gmsynth-lv2/Makefile b/audio/gmsynth-lv2/Makefile
index c4b6a0c36ab1..f0484eeae9f9 100644
--- a/audio/gmsynth-lv2/Makefile
+++ b/audio/gmsynth-lv2/Makefile
@@ -1,11 +1,12 @@
PORTNAME= gmsynth
DISTVERSIONPREFIX= v
-DISTVERSION= 0.5.0
+DISTVERSION= 0.6.0
CATEGORIES= audio
PKGNAMESUFFIX= -lv2
MAINTAINER= yuri@FreeBSD.org
COMMENT= General MIDI LV2 Synth
+WWW= https://x42-plugins.com/x42/x42-gmsynth
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/COPYING
@@ -14,10 +15,13 @@ BUILD_DEPENDS= lv2>0:audio/lv2
# FluidSynth is left bundled based on the project owner's request: https://github.com/x42/gmsynth.lv2/issues/2#issuecomment-441458303
USES= gmake gnome pkgconfig
+USE_GNOME= glib20
+
USE_GITHUB= yes
GH_ACCOUNT= x42
GH_PROJECT= ${PORTNAME}.lv2
-USE_GNOME= glib20
+
+BINARY_ALIAS= git=false
PLIST_FILES= lib/lv2/${PORTNAME}.lv2/GeneralUser_LV2.sf2 \
lib/lv2/${PORTNAME}.lv2/${PORTNAME}.so \
@@ -29,6 +33,6 @@ OPTIONS_DEFINE_i386= SIMD
OPTIONS_DEFAULT_amd64= SIMD
OPTIONS_DEFAULT_i386= SIMD
-SIMD_MAKE_ENV= PORT_SIMD_FLAGS="-msse -msse2 -mfpmath=sse"
+SIMD_MAKE_ENV= HAVE_SSE=yes
.include <bsd.port.mk>