aboutsummaryrefslogtreecommitdiff
path: root/audio/gnome-music/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'audio/gnome-music/Makefile')
-rw-r--r--audio/gnome-music/Makefile33
1 files changed, 33 insertions, 0 deletions
diff --git a/audio/gnome-music/Makefile b/audio/gnome-music/Makefile
new file mode 100644
index 000000000000..4645b39e4e88
--- /dev/null
+++ b/audio/gnome-music/Makefile
@@ -0,0 +1,33 @@
+# Created by: Gustau Perez <gustau.perez@gmail.com>
+# $FreeBSD$
+# $MCom: ports/trunk/audio/gnome-music/Makefile 19994 2014-10-19 08:07:16Z gusi $
+
+PORTNAME= gnome-music
+PORTVERSION= 3.14.0
+CATEGORIES= audio gnome
+MASTER_SITES= GNOME
+DIST_SUBDIR= gnome3
+
+MAINTAINER= gnome@FreeBSD.org
+COMMENT= GNOME music playing application
+
+BUILD_DEPENDS= itstool:${PORTSDIR}/textproc/itstool
+LIB_DEPENDS= libgrilo-0.2.so:${PORTSDIR}/net/grilo \
+ libmediaart-1.0.so:${PORTSDIR}/multimedia/libmediaart
+
+USES= gettext gmake libtool pathfix pkgconfig \
+ python:3 tar:xz
+USE_LDCONFIG= yes
+USE_GNOME= gnomedesktop3 gnomeprefix gtk30 intlhack \
+ introspection:build
+GNU_CONFIGURE= yes
+USE_GSTREAMER1= ogg mad
+INSTALLS_ICONS= yes
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
+MAKE_ENV= XDG_CACHE_HOME=${WRKDIR}
+INSTALL_TARGET= install-strip
+
+GLIB_SCHEMAS= org.gnome.Music.gschema.xml
+
+.include <bsd.port.mk>