aboutsummaryrefslogtreecommitdiff
path: root/audio/gnome-podcasts/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'audio/gnome-podcasts/Makefile')
-rw-r--r--audio/gnome-podcasts/Makefile295
1 files changed, 18 insertions, 277 deletions
diff --git a/audio/gnome-podcasts/Makefile b/audio/gnome-podcasts/Makefile
index c05e44015d09..78d40df65b30 100644
--- a/audio/gnome-podcasts/Makefile
+++ b/audio/gnome-podcasts/Makefile
@@ -1,303 +1,44 @@
PORTNAME= podcasts
-DISTVERSION= 0.4.9
-PORTREVISION= 3
+DISTVERSION= 0.7.1
CATEGORIES= audio
PKGNAMEPREFIX= gnome-
-PATCH_SITES= ${GL_SITE}/${GL_ACCOUNT}/${GL_PROJECT}/-/commit/
-PATCHFILES+= 9890d296fd0a.patch:-p1 # https://gitlab.gnome.org/World/podcasts/-/merge_requests/200
-
MAINTAINER= jbeich@FreeBSD.org
COMMENT= Podcast app for GNOME
+WWW= https://gitlab.gnome.org/World/podcasts
LICENSE= GPLv3+
LICENSE_FILE= ${WRKSRC}/LICENSE
BUILD_DEPENDS= bash:shells/bash
-LIB_DEPENDS= libdbus-1.so:devel/dbus \
- libhandy-1.so:x11-toolkits/libhandy
-USES= cargo gettext gnome meson pkgconfig python:build shebangfix sqlite ssl
+USES= cargo gettext gnome gstreamer meson pkgconfig sqlite ssl
USE_GITLAB= yes
-USE_GNOME= gdkpixbuf2 gtk30
-USE_GSTREAMER1= bad good libav
+USE_GNOME= gdkpixbuf2 gtk40 libadwaita
+USE_GSTREAMER= bad good libav
GL_SITE= https://gitlab.gnome.org
GL_ACCOUNT= World
-GL_COMMIT= e93a7ddabfe8289138280c3f613038b809b5033d
-SHEBANG_FILES= scripts/cargo.sh scripts/compile-gschema.py
MAKE_ENV= ${CARGO_ENV}
-GLIB_SCHEMAS= org.gnome.Podcasts.gschema.xml
-
-CARGO_CRATES= aho-corasick-0.7.13 \
- ammonia-3.1.0 \
- ansi_term-0.11.0 \
- anyhow-1.0.32 \
- atk-0.9.0 \
- atk-sys-0.10.0 \
- atty-0.2.14 \
- autocfg-1.0.0 \
- base64-0.12.3 \
- bitflags-1.2.1 \
- bumpalo-3.4.0 \
- byteorder-1.3.4 \
- bytes-0.5.6 \
- cairo-rs-0.9.1 \
- cairo-sys-rs-0.10.0 \
- cc-1.0.58 \
- cfg-if-0.1.10 \
- chrono-0.4.15 \
- cloudabi-0.1.0 \
- core-foundation-0.7.0 \
- core-foundation-sys-0.7.0 \
- crossbeam-channel-0.4.3 \
- crossbeam-deque-0.7.3 \
- crossbeam-epoch-0.8.2 \
- crossbeam-queue-0.2.3 \
- crossbeam-utils-0.7.2 \
- ctor-0.1.15 \
- darling-0.10.2 \
- darling_core-0.10.2 \
- darling_macro-0.10.2 \
- dbus-0.6.5 \
- derive_builder-0.9.0 \
- derive_builder_core-0.9.0 \
- diesel-1.4.5 \
- diesel_derives-1.4.1 \
- diesel_migrations-1.4.0 \
- difference-2.0.0 \
- dtoa-0.4.6 \
- either-1.6.0 \
- encoding_rs-0.8.23 \
- env_logger-0.7.1 \
- fnv-1.0.7 \
- foreign-types-0.3.2 \
- foreign-types-shared-0.1.1 \
- fragile-1.0.0 \
- fuchsia-cprng-0.1.1 \
- fuchsia-zircon-0.3.3 \
- fuchsia-zircon-sys-0.3.3 \
- futf-0.1.4 \
- futures-0.3.5 \
- futures-channel-0.3.5 \
- futures-core-0.3.5 \
- futures-executor-0.3.5 \
- futures-io-0.3.5 \
- futures-macro-0.3.5 \
- futures-sink-0.3.5 \
- futures-task-0.3.5 \
- futures-util-0.3.5 \
- gdk-0.13.1 \
- gdk-pixbuf-0.9.0 \
- gdk-pixbuf-sys-0.10.0 \
- gdk-sys-0.10.0 \
- getrandom-0.1.14 \
- gio-0.9.0 \
- gio-sys-0.10.0 \
- glib-0.10.1 \
- glib-macros-0.10.1 \
- glib-sys-0.10.0 \
- glob-0.3.0 \
- gobject-sys-0.10.0 \
- gstreamer-0.16.2 \
- gstreamer-base-0.16.0 \
- gstreamer-base-sys-0.9.0 \
- gstreamer-player-0.16.0 \
- gstreamer-player-sys-0.9.0 \
- gstreamer-sys-0.9.0 \
- gstreamer-video-0.16.0 \
- gstreamer-video-sys-0.9.0 \
- gtk-0.9.1 \
- gtk-sys-0.10.0 \
- h2-0.2.6 \
- hashbrown-0.8.2 \
- heck-0.3.1 \
- hermit-abi-0.1.15 \
- html2text-0.1.14 \
- html5ever-0.25.1 \
- http-0.2.1 \
- http-body-0.3.1 \
- httparse-1.3.4 \
- humansize-1.1.0 \
- humantime-1.3.0 \
- hyper-0.13.7 \
- hyper-tls-0.4.3 \
- ident_case-1.0.1 \
- idna-0.2.0 \
- indexmap-1.5.1 \
- instant-0.1.6 \
- iovec-0.1.4 \
- ipnet-2.3.0 \
- itertools-0.9.0 \
- itoa-0.4.6 \
- js-sys-0.3.44 \
- kernel32-sys-0.2.2 \
- lazy_static-1.4.0 \
- libc-0.2.74 \
- libdbus-sys-0.2.1 \
- libhandy-0.7.0 \
- libhandy-sys-0.7.0 \
- libsqlite3-sys-0.18.0 \
- locale_config-0.2.3 \
- lock_api-0.4.1 \
- log-0.4.11 \
- mac-0.1.1 \
- maplit-1.0.2 \
- markup5ever-0.10.0 \
- markup5ever_rcdom-0.1.0 \
- matches-0.1.8 \
- maybe-uninit-2.0.0 \
- memchr-2.3.3 \
- memoffset-0.5.5 \
- migrations_internals-1.4.1 \
- migrations_macros-1.4.2 \
- mime-0.3.16 \
- mime_guess-2.0.3 \
- mio-0.6.22 \
- miow-0.2.1 \
- mpris-player-0.6.0 \
- muldiv-0.2.1 \
- native-tls-0.2.4 \
- net2-0.2.34 \
- new_debug_unreachable-1.0.4 \
- num-integer-0.1.43 \
- num-rational-0.3.0 \
- num-traits-0.2.12 \
- num_cpus-1.13.0 \
- once_cell-1.4.1 \
- open-1.4.0 \
- openssl-0.10.30 \
- openssl-probe-0.1.2 \
- openssl-sys-0.9.58 \
- output_vt100-0.1.2 \
- pango-0.9.1 \
- pango-sys-0.10.0 \
- parking_lot-0.11.0 \
- parking_lot_core-0.8.0 \
- paste-0.1.18 \
- paste-impl-0.1.18 \
- percent-encoding-2.1.0 \
- phf-0.8.0 \
- phf_codegen-0.8.0 \
- phf_generator-0.8.0 \
- phf_shared-0.8.0 \
- pin-project-0.4.23 \
- pin-project-internal-0.4.23 \
- pin-project-lite-0.1.7 \
- pin-utils-0.1.0 \
- pkg-config-0.3.18 \
- ppv-lite86-0.2.8 \
- precomputed-hash-0.1.1 \
- pretty-hex-0.1.1 \
- pretty_assertions-0.6.1 \
- pretty_env_logger-0.4.0 \
- proc-macro-crate-0.1.5 \
- proc-macro-error-1.0.4 \
- proc-macro-error-attr-1.0.4 \
- proc-macro-hack-0.5.18 \
- proc-macro-nested-0.1.6 \
- proc-macro2-1.0.19 \
- quick-error-1.2.3 \
- quick-xml-0.17.2 \
- quote-1.0.7 \
- r2d2-0.8.9 \
- rand-0.4.6 \
- rand-0.7.3 \
- rand_chacha-0.2.2 \
- rand_core-0.3.1 \
- rand_core-0.4.2 \
- rand_core-0.5.1 \
- rand_hc-0.2.0 \
- rand_pcg-0.2.1 \
- rayon-1.3.1 \
- rayon-core-1.7.1 \
- rdrand-0.4.0 \
- redox_syscall-0.1.57 \
- regex-1.3.9 \
- regex-syntax-0.6.18 \
- remove_dir_all-0.5.3 \
- reqwest-0.10.7 \
- rfc822_sanitizer-0.3.4 \
- rss-1.9.0 \
- ryu-1.0.5 \
- schannel-0.1.19 \
- scheduled-thread-pool-0.2.5 \
- scopeguard-1.1.0 \
- security-framework-0.4.4 \
- security-framework-sys-0.4.3 \
- serde-1.0.115 \
- serde_derive-1.0.115 \
- serde_json-1.0.57 \
- serde_urlencoded-0.6.1 \
- siphasher-0.3.3 \
- slab-0.4.2 \
- smallvec-1.4.2 \
- socket2-0.3.12 \
- string_cache-0.8.0 \
- string_cache_codegen-0.5.1 \
- strsim-0.9.3 \
- strum-0.18.0 \
- strum_macros-0.18.0 \
- syn-1.0.38 \
- system-deps-1.3.2 \
- tempdir-0.3.7 \
- tempfile-3.1.0 \
- tendril-0.4.1 \
- termcolor-1.1.0 \
- thiserror-1.0.20 \
- thiserror-impl-1.0.20 \
- thread_local-1.0.1 \
- time-0.1.43 \
- tinyvec-0.3.4 \
- tokio-0.2.22 \
- tokio-macros-0.2.5 \
- tokio-tls-0.3.1 \
- tokio-util-0.3.1 \
- toml-0.5.6 \
- tower-service-0.3.0 \
- tracing-0.1.19 \
- tracing-core-0.1.14 \
- try-lock-0.2.3 \
- unicase-2.6.0 \
- unicode-bidi-0.3.4 \
- unicode-normalization-0.1.13 \
- unicode-segmentation-1.6.0 \
- unicode-width-0.1.8 \
- unicode-xid-0.2.1 \
- url-2.1.1 \
- utf-8-0.7.5 \
- vcpkg-0.2.10 \
- version-compare-0.0.10 \
- version_check-0.9.2 \
- want-0.3.0 \
- wasi-0.9.0+wasi-snapshot-preview1 \
- wasm-bindgen-0.2.67 \
- wasm-bindgen-backend-0.2.67 \
- wasm-bindgen-futures-0.4.17 \
- wasm-bindgen-macro-0.2.67 \
- wasm-bindgen-macro-support-0.2.67 \
- wasm-bindgen-shared-0.2.67 \
- web-sys-0.3.44 \
- winapi-0.2.8 \
- winapi-0.3.9 \
- winapi-build-0.1.1 \
- winapi-i686-pc-windows-gnu-0.4.0 \
- winapi-util-0.1.5 \
- winapi-x86_64-pc-windows-gnu-0.4.0 \
- winreg-0.7.0 \
- ws2_32-sys-0.2.1 \
- xdg-2.2.0 \
- xml-rs-0.8.3 \
- xml5ever-0.16.1 \
- gettext-rs,gettext-sys@git+https://github.com/danigm/gettext-rs?branch=no-gettext\#61938b9f5f1d3bdc31f9839f53fabe5ccf136a78
CARGO_BUILD= no
CARGO_INSTALL= no
CARGO_TEST= no
+GLIB_SCHEMAS= org.gnome.Podcasts.gschema.xml
+
+.include <bsd.port.options.mk>
+
+.if ${ARCH} == i386 || ${ARCH} == powerpc
+# https://github.com/rust-lang/rust/issues/85598
+LTO_UNSAFE= yes
+.endif
post-patch:
@${REINPLACE_CMD} -e '/dependency.*openssl/d' \
+ -e '/update_desktop_database/d' \
${WRKSRC}/meson.build
# Make each cargo subcommand very verbose
- @${REINPLACE_CMD} -e "/ARGS=/s/()/('--verbose' '--verbose')/" \
- ${WRKSRC}/scripts/cargo.sh
+# Add explicit <triple> subdir for --target from USES=cargo
+ @${REINPLACE_CMD} -e "/cargo_options =/s/ '--/&verbose', &verbose', &/" \
+ -e "/cp/s,'${PORTNAME}-gtk' / 'src',& / '${CARGO_BUILD_TARGET}'," \
+ ${WRKSRC}/${PORTNAME}-gtk/src/meson.build
.include <bsd.port.mk>