aboutsummaryrefslogtreecommitdiff
path: root/audio/gsequencer/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'audio/gsequencer/Makefile')
-rw-r--r--audio/gsequencer/Makefile17
1 files changed, 11 insertions, 6 deletions
diff --git a/audio/gsequencer/Makefile b/audio/gsequencer/Makefile
index 5d6fcccd1721..2717af3ddeed 100644
--- a/audio/gsequencer/Makefile
+++ b/audio/gsequencer/Makefile
@@ -1,10 +1,12 @@
PORTNAME= gsequencer
-DISTVERSION= 3.8.13
+DISTVERSION= 6.5.2
+PORTREVISION= 1
CATEGORIES= audio
MASTER_SITES= SAVANNAH/gsequencer/${DISTVERSION:R}.x
MAINTAINER= yuri@FreeBSD.org
COMMENT= Advanced Gtk+ sequencer
+WWW= https://nongnu.org/gsequencer/
LICENSE= GPLv3
LICENSE_FILE= ${WRKSRC}/COPYING
@@ -15,23 +17,27 @@ LIB_DEPENDS= libasound.so:audio/alsa-lib \
libfftw3.so:math/fftw3 \
libfontconfig.so:x11-fonts/fontconfig \
libfreetype.so:print/freetype2 \
+ libgraphene-1.0.so:graphics/graphene \
+ libharfbuzz.so:print/harfbuzz \
libinstpatch-1.0.so:audio/libinstpatch \
+ libjson-glib-1.0.so:devel/json-glib \
libsamplerate.so:audio/libsamplerate \
libsndfile.so:audio/libsndfile \
- libsoup-2.4.so:devel/libsoup \
+ libsoup-3.0.so:devel/libsoup3 \
libuuid.so:misc/e2fsprogs-libuuid \
+ libvulkan.so:graphics/vulkan-loader \
libwebkit2gtk-4.0.so:www/webkit2-gtk3
RUN_DEPENDS= dssi>0:audio/dssi
-USES= desktop-file-utils gettext-runtime gettext-tools gmake gnome libtool localbase pkgconfig shared-mime-info xorg
-USE_GNOME= atk cairo gdkpixbuf2 glib20 gtk30 libxml2 pango
+USES= desktop-file-utils gettext-runtime gettext-tools gmake gnome gstreamer libtool localbase pkgconfig shared-mime-info xorg
+USE_GNOME= atk cairo gdkpixbuf2 glib20 gtk40 libxml2 pango
USE_XORG= x11
-USE_GSTREAMER1= yes
USE_GCC= yes # the project uses gnu99 extensions, clang fails even with USE_CSTD=gnu99. Suggestions how to build with clang are welcome.
USE_CSTD= gnu99
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
+GNU_CONFIGURE_MANPREFIX= ${PREFIX}/share
CONFIGURE_ARGS= --disable-alsa --enable-oss --disable-introspection --disable-rt
CPPFLAGS+= -DAGS_LICENSE_FILENAME=\\\"${LOCALBASE}/share/licenses/${PKGNAME}/${LICENSE}\\\" \
@@ -39,7 +45,6 @@ CPPFLAGS+= -DAGS_LICENSE_FILENAME=\\\"${LOCALBASE}/share/licenses/${PKGNAME}/${L
LDFLAGS+= -luuid
INSTALL_TARGET= install-strip
-INSTALLS_ICONS= yes
PLIST_SUB= PORTVERSION=${PORTVERSION}