aboutsummaryrefslogtreecommitdiff
path: root/audio/hpsjam/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'audio/hpsjam/Makefile')
-rw-r--r--audio/hpsjam/Makefile28
1 files changed, 14 insertions, 14 deletions
diff --git a/audio/hpsjam/Makefile b/audio/hpsjam/Makefile
index b64bb14a35d0..83c3ea2703c6 100644
--- a/audio/hpsjam/Makefile
+++ b/audio/hpsjam/Makefile
@@ -1,29 +1,29 @@
-# Created by: Hans Petter Selasky <hselasky@freebsd.org>
-
PORTNAME= hpsjam
DISTVERSIONPREFIX= v
-DISTVERSION= 1.0.16
+DISTVERSION= 1.2.8
CATEGORIES= audio
-MAINTAINER= hselasky@FreeBSD.org
+MAINTAINER= ports@FreeBSD.org
COMMENT= Online jamming client and server tool
+WWW= https://github.com/hselasky/hpsjam
LICENSE= BSD2CLAUSE
-LIB_DEPENDS= \
- libfftw3.so:math/fftw3 \
- libjack.so:audio/jack
+LIB_DEPENDS= libjack.so:audio/jack
USES= compiler:c++11-lang gl qmake qt:5 tar:bzip2
-USE_GL= gl
-USE_QT= buildtools_build core gui widgets svg
-
USE_GITHUB= yes
GH_ACCOUNT= hselasky
+GH_TUPLE= mborgerding:kissfft:131.1.0:a/kissfft
+USE_GL= gl
+USE_QT= core gui svg widgets buildtools:build
+USE_RC_SUBR= ${PORTNAME}_server
+
+USER= nobody
+SUB_LIST= USER=${USER}
-PLIST_FILES= \
- bin/HpsJam \
- share/pixmaps/HpsJam.png \
- share/applications/HpsJam.desktop
+PLIST_FILES= bin/HpsJam \
+ share/applications/HpsJam.desktop \
+ share/pixmaps/HpsJam.png
.include <bsd.port.mk>