aboutsummaryrefslogtreecommitdiff
path: root/audio/icecast2/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'audio/icecast2/Makefile')
-rw-r--r--audio/icecast2/Makefile60
1 files changed, 0 insertions, 60 deletions
diff --git a/audio/icecast2/Makefile b/audio/icecast2/Makefile
deleted file mode 100644
index ac3cd551aacf..000000000000
--- a/audio/icecast2/Makefile
+++ /dev/null
@@ -1,60 +0,0 @@
-# New ports collection makefile for: icecast
-# Version required: 1.3.0
-# Date created: 28 Jan 1999
-# Whom: Chip Marshall <chip@eboai.org>
-#
-# $FreeBSD$
-#
-
-DISTNAME= icecast-1.3.0
-CATEGORIES= audio net
-MASTER_SITES= http://www.icecast.org/releases/ \
- ftp://ftp.eboai.org/pub/icecast/
-
-MAINTAINER= chip@eboai.org
-
-WRKSRC= ${WRKDIR}/icecast-1.3
-
-GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --with-libwrap
-
-do-configure:
- cd ${WRKSRC} && ${SH} ./configure ${CONFIGURE_ARGS}
- cd ${WRKSRC}/liveice && ${SH} ./configure ${CONFIGURE_ARGS}
-
-do-build:
- cd ${WRKSRC} && ${MAKE}
- cd ${WRKSRC} && ${MAKE} mkpasswd
- cd ${WRKSRC}/liveice && ${MAKE}
-
-do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/icecast ${PREFIX}/sbin
- ${INSTALL_PROGRAM} ${WRKSRC}/mkpasswd ${PREFIX}/bin
- ${INSTALL_PROGRAM} ${WRKSRC}/shout/listen ${PREFIX}/bin
- ${INSTALL_PROGRAM} ${WRKSRC}/shout/shout ${PREFIX}/bin
- ${INSTALL_PROGRAM} ${WRKSRC}/shout/calibrate ${PREFIX}/bin
- ${INSTALL_PROGRAM} ${WRKSRC}/shout/stresstest ${PREFIX}/bin
- ${INSTALL_PROGRAM} ${WRKSRC}/liveice/liveice ${PREFIX}/bin
- ${INSTALL_SCRIPT} ${WRKSRC}/shout/iceplay ${PREFIX}/bin
-.if !defined(NOPORTDOCS)
- ${MKDIR} ${PREFIX}/share/doc/icecast
- ${INSTALL_MAN} ${WRKSRC}/doc/* ${PREFIX}/share/doc/icecast
- ${INSTALL_MAN} ${WRKSRC}/liveice/README.liveice ${PREFIX}/share/doc/icecast
- ${INSTALL_MAN} ${WRKSRC}/liveice/README.xingmp3enc ${PREFIX}/share/doc/icecast
- ${INSTALL_MAN} ${WRKSRC}/liveice/README_new_mixer.txt ${PREFIX}/share/doc/icecast
- ${MKDIR} ${PREFIX}/share/examples/icecast
- ${INSTALL_MAN} ${WRKSRC}/icecast.conf ${PREFIX}/share/examples/icecast
- ${INSTALL_MAN} ${WRKSRC}/liveice/liveice.cfg ${PREFIX}/share/examples/icecast
- ${INSTALL_MAN} ${WRKSRC}/shout/shoutrc.example ${PREFIX}/share/examples/icecast
- ${INSTALL_MAN} ${WRKSRC}/shout/playlist.example ${PREFIX}/share/examples/icecast
- ${INSTALL_MAN} ${WRKSRC}/shout/radio.tcl.example ${PREFIX}/share/examples/icecast
- ${MKDIR} ${PREFIX}/share/examples/icecast/icedir
- ${INSTALL_MAN} ${WRKSRC}/icedir/* ${PREFIX}/share/examples/icecast/icedir
- ${MKDIR} ${PREFIX}/share/examples/icecast/templates
- ${INSTALL_MAN} ${WRKSRC}/templates/* ${PREFIX}/share/examples/icecast/templates
- ${INSTALL_MAN} ${WRKSRC}/liveice/frontend.tcl ${PREFIX}/share/examples/icecast
- ${INSTALL_MAN} ${WRKSRC}/liveice/liveiceconfigure.tk ${PREFIX}/share/examples/icecast
-.endif
- @${CAT} ${PKGDIR}/MESSAGE
-
-.include <bsd.port.mk>