aboutsummaryrefslogtreecommitdiff
path: root/audio/jamulus/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'audio/jamulus/Makefile')
-rw-r--r--audio/jamulus/Makefile11
1 files changed, 7 insertions, 4 deletions
diff --git a/audio/jamulus/Makefile b/audio/jamulus/Makefile
index 58a4fc3db590..e1c4e68c4154 100644
--- a/audio/jamulus/Makefile
+++ b/audio/jamulus/Makefile
@@ -1,10 +1,11 @@
PORTNAME= jamulus
DISTVERSIONPREFIX= r
-DISTVERSION= 3_9_0
+DISTVERSION= 3_10_0
CATEGORIES= audio
MAINTAINER= yuri@FreeBSD.org
COMMENT= Internet jam session software
+WWW= https://jamulus.io
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/COPYING
@@ -16,7 +17,7 @@ FLAVOR?= ${FLAVORS:[1]}
server_PKGNAMESUFFIX= -server
USES= compiler:c++11-lang gl pkgconfig qmake qt:5
-USE_QT= concurrent core multimedia network xml buildtools_build linguisttools_build
+USE_QT= concurrent core multimedia network xml buildtools:build linguisttools:build
USE_GL= gl
USE_GITHUB= yes
@@ -28,6 +29,9 @@ USE_QT+= gui widgets
PLIST_FILES= bin/${PORTNAME} \
share/applications/${PORTNAME}.desktop \
share/applications/${PORTNAME}-server.desktop \
+ share/icons/hicolor/512x512/apps/io.${PORTNAME}.${PORTNAME}.png \
+ share/icons/hicolor/scalable/apps/io.${PORTNAME}.${PORTNAME}.svg \
+ share/icons/hicolor/scalable/apps/io.${PORTNAME}.${PORTNAME}server.svg \
share/man/man1/Jamulus.1.gz \
share/pixmaps/${PORTNAME}.png \
share/pixmaps/${PORTNAME}-server.png
@@ -49,8 +53,7 @@ PORTSCOUT= limit:^r\d+_ # prevent malformatted tags, like 'latest'
.if ${FLAVOR:U} == desktop
post-install:
# workaround for https://gitlab.xfce.org/xfce/xfdesktop/-/issues/131
- ${MV} ${STAGEDIR}${PREFIX}/share/icons/hicolor/512x512/apps/jamulus.png ${STAGEDIR}${PREFIX}/share/pixmaps/
- ${RM} -r ${STAGEDIR}${PREFIX}/share/icons
+ ${RLN} ${STAGEDIR}${PREFIX}/share/icons/hicolor/512x512/apps/io.jamulus.jamulus.png ${STAGEDIR}${PREFIX}/share/pixmaps/jamulus.png
# add Jamulus Server menu item which is simply 'jamulus -s' with a special icon
${CP} ${STAGEDIR}${PREFIX}/share/applications/${PORTNAME}.desktop ${STAGEDIR}${PREFIX}/share/applications/${PORTNAME}-server.desktop
${REINPLACE_CMD} -i '' ' \