aboutsummaryrefslogtreecommitdiff
path: root/audio/juk/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'audio/juk/Makefile')
-rw-r--r--audio/juk/Makefile13
1 files changed, 7 insertions, 6 deletions
diff --git a/audio/juk/Makefile b/audio/juk/Makefile
index 2adf26431b1d..aab3b6b5aef3 100644
--- a/audio/juk/Makefile
+++ b/audio/juk/Makefile
@@ -1,23 +1,24 @@
PORTNAME= juk
DISTVERSION= ${KDE_APPLICATIONS_VERSION}
-PORTREVISION= 1
CATEGORIES= audio kde kde-applications
MAINTAINER= kde@FreeBSD.org
COMMENT= Jukebox, tagger and music collection manager
+WWW= https://www.kde.org/applications/multimedia/juk/
LICENSE= GPLv2
LIB_DEPENDS= libtag.so:audio/taglib
-USES= cmake compiler:c++11-lang kde:5 qt:5 tar:xz
+USES= cmake compiler:c++11-lang kde:5 qt:5 tar:xz xorg
USE_KDE= auth bookmarks codecs completion config configwidgets \
coreaddons crash dbusaddons globalaccel i18n iconthemes itemviews \
- jobwidgets kio notifications service solid sonnet textwidgets \
+ jobwidgets kio notifications phonon service solid sonnet textwidgets \
wallet widgetsaddons windowsystem xmlgui \
- ecm_build
-USE_QT= concurrent core dbus gui network phonon4 svg widgets xml \
- buildtools_build qmake_build testlib_build
+ ecm:build
+USE_QT= concurrent core dbus gui network svg widgets xml \
+ buildtools:build qmake:build testlib:build
+USE_XORG= x11
OPTIONS_DEFINE= DOCS