aboutsummaryrefslogtreecommitdiff
path: root/audio/libamrwb/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'audio/libamrwb/Makefile')
-rw-r--r--audio/libamrwb/Makefile17
1 files changed, 8 insertions, 9 deletions
diff --git a/audio/libamrwb/Makefile b/audio/libamrwb/Makefile
index dee7e7e37945..2f49734ef938 100644
--- a/audio/libamrwb/Makefile
+++ b/audio/libamrwb/Makefile
@@ -1,33 +1,32 @@
-# Created by: Tatsuki Makino <tatsuki_makino@hotmail.com>
-
PORTNAME= libamrwb
-PORTVERSION= 11.0.0.0
-PORTREVISION= 2
+DISTVERSION= 11.0.0.0
+PORTREVISION= 3
CATEGORIES= audio
MASTER_SITES= http://www.penguin.cz/~utx/ftp/amr/ \
- http://www.3gpp.org/ftp/Specs/archive/26_series/26.204/:SRC26204
-DISTNAME= amrwb-${DISTVERSION}
+ https://www.3gpp.org/ftp/Specs/archive/26_series/26.204/:SRC26204
+DISTNAME= amrwb-${DISTVERSIONFULL}
DISTFILES= ${DISTNAME}${EXTRACT_SUFX} ${SRC26204}:SRC26204
DIST_SUBDIR= ${PORTNAME}
EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX}
MAINTAINER= tatsuki_makino@hotmail.com
COMMENT= 3GPP Adaptive Multi-Rate - Wideband (AMR-WB) Speech Codec
+WWW= http://www.penguin.cz/~utx/amr
LICENSE= BSD3CLAUSE 3GPP
LICENSE_COMB= multi
LICENSE_NAME_3GPP= 3GPP
LICENSE_TEXT_3GPP= unclear legal status, probably need licenses from 3GPP and more
LICENSE_PERMS_3GPP= no-dist-mirror no-dist-sell no-pkg-mirror no-pkg-sell auto-accept
-LICENSE_DISTFILES_BSD3CLAUSE= ${DISTNAME}${EXTRACT_SUFX}
LICENSE_DISTFILES_3GPP= ${SRC26204}
+LICENSE_DISTFILES_BSD3CLAUSE= ${DISTNAME}${EXTRACT_SUFX}
-USES= gmake tar:bzip2 libtool
+USES= autoreconf gmake tar:bzip2 libtool
+USE_LDCONFIG= yes
PORTDOCS= AUTHORS COPYING ChangeLog NEWS README TODO readme.txt
GNU_CONFIGURE= yes
INSTALL_TARGET= install-strip
SUB_FILES= pkg-message
-USE_LDCONFIG= yes
OPTIONS_DEFINE= DOCS