aboutsummaryrefslogtreecommitdiff
path: root/audio/libopenmpt/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'audio/libopenmpt/Makefile')
-rw-r--r--audio/libopenmpt/Makefile56
1 files changed, 36 insertions, 20 deletions
diff --git a/audio/libopenmpt/Makefile b/audio/libopenmpt/Makefile
index cff80e9a91a2..c14441dd9a29 100644
--- a/audio/libopenmpt/Makefile
+++ b/audio/libopenmpt/Makefile
@@ -1,7 +1,5 @@
-# Created by: Emanuel Haupt <ehaupt@FreeBSD.org>
-
PORTNAME= libopenmpt
-PORTVERSION= 0.5.11
+DISTVERSION= 0.7.6
DISTVERSIONSUFFIX= +release.autotools
CATEGORIES= audio
MASTER_SITES= https://lib.openmpt.org/files/libopenmpt/src/ \
@@ -9,35 +7,50 @@ MASTER_SITES= https://lib.openmpt.org/files/libopenmpt/src/ \
MAINTAINER= ehaupt@FreeBSD.org
COMMENT= Module music library based on OpenMPT
+WWW= https://lib.openmpt.org/
LICENSE= BSD3CLAUSE
LICENSE_FILE= ${WRKSRC}/LICENSE
-USES= compiler:c++11-lang gmake libtool pkgconfig
+LIB_DEPENDS= libmpg123.so:audio/mpg123 \
+ libvorbis.so:audio/libvorbis
+
+USES= compiler:c++17-lang cpe gmake libtool pathfix pkgconfig
+CPE_VENDOR= openmpt
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
+GNU_CONFIGURE_MANPREFIX= ${PREFIX}/share
+
+CONFIGURE_ARGS= --disable-doxygen-doc \
+ --with-mpg123 \
+ --with-vorbis \
+ --with-vorbisfile \
+ --without-portaudiocpp
+
+TEST_TARGET= check
-CONFIGURE_ARGS+= --without-portaudiocpp
+OPTIONS_DEFINE= DOCS EXAMPLES OPENMPT123 PULSEAUDIO
+OPTIONS_DEFAULT= OPENMPT123
+OPTIONS_SUB= yes
-OPTIONS_DEFINE= DOCS EXAMPLES FLAC MPG123 OGG PORTAUDIO PULSEAUDIO \
- SNDFILE VORBIS
-OPTIONS_DEFAULT= FLAC MPG123 OGG PORTAUDIO SNDFILE VORBIS
+OPENMPT123_DESC= Enable command line player
+PULSEAUDIO_DESC= Enable PulseAudio support for openmpt123
-FLAC_LIB_DEPENDS= libFLAC.so:audio/flac
-FLAC_CONFIGURE_WITH= flac
-MPG123_LIB_DEPENDS= libmpg123.so:audio/mpg123
-MPG123_CONFIGURE_WITH= mpg123
-OGG_LIB_DEPENDS= libogg.so:audio/libogg
-OGG_CONFIGURE_WITH= ogg
-PORTAUDIO_LIB_DEPENDS= libportaudio.so:audio/portaudio
-PORTAUDIO_CONFIGURE_WITH= portaudio
+OPENMPT123_LIB_DEPENDS= libFLAC.so:audio/flac \
+ libogg.so:audio/libogg \
+ libportaudio.so:audio/portaudio \
+ libsndfile.so:audio/libsndfile
+OPENMPT123_CONFIGURE_OFF= --disable-openmpt123
+OPENMPT123_CONFIGURE_WITH= flac portaudio sndfile
+
+PULSEAUDIO_IMPLIES= OPENMPT123
PULSEAUDIO_LIB_DEPENDS= libpulse.so:audio/pulseaudio
PULSEAUDIO_CONFIGURE_WITH= pulseaudio
-SNDFILE_LIB_DEPENDS= libsndfile.so:audio/libsndfile
-SNDFILE_CONFIGURE_WITH= sndfile
-VORBIS_LIB_DEPENDS= libvorbis.so:audio/libvorbis
-VORBIS_CONFIGURE_WITH= vorbis vorbisfile
+
+pre-configure:
+ @${REINPLACE_CMD} -e 's/+release.autotools//' \
+ ${PATCH_WRKSRC}/configure
post-install:
${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/libopenmpt.so.*
@@ -48,4 +61,7 @@ post-install-DOCS-on:
post-install-EXAMPLES-on:
@${MV} ${STAGEDIR}${DOCSDIR}/examples ${STAGEDIR}${EXAMPLESDIR}
+post-install-EXAMPLES-off:
+ @${RM} -rf ${STAGEDIR}${DOCSDIR}/examples
+
.include <bsd.port.mk>