aboutsummaryrefslogtreecommitdiff
path: root/audio/linuxsampler/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'audio/linuxsampler/Makefile')
-rw-r--r--audio/linuxsampler/Makefile14
1 files changed, 6 insertions, 8 deletions
diff --git a/audio/linuxsampler/Makefile b/audio/linuxsampler/Makefile
index 33db4858c035..b18e2cedd815 100644
--- a/audio/linuxsampler/Makefile
+++ b/audio/linuxsampler/Makefile
@@ -1,13 +1,11 @@
-# Created by: trasz <trasz@pin.if.uz.zgora.pl>
-
PORTNAME= linuxsampler
-DISTVERSION= 2.2.0
-PORTREVISION= 1
+DISTVERSION= 2.3.1
CATEGORIES= audio
MASTER_SITES= https://download.linuxsampler.org/packages/
MAINTAINER= yuri@FreeBSD.org
COMMENT= Modular MIDI sampler
+WWW= https://www.linuxsampler.org/
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/COPYING
@@ -15,8 +13,7 @@ LICENSE_FILE= ${WRKSRC}/COPYING
ONLY_FOR_ARCHS= amd64 i386
ONLY_FOR_ARCHS_REASON= not yet ported to this architecture
-BUILD_DEPENDS= lv2>0:audio/lv2 \
- dssi>0:audio/dssi
+BUILD_DEPENDS= lv2>0:audio/lv2
LIB_DEPENDS= libgig.so:audio/libgig \
libsndfile.so:audio/libsndfile \
libuuid.so:misc/e2fsprogs-libuuid
@@ -25,11 +22,10 @@ USES= bison:wrapper compiler:c++14-lang gmake libtool localbase pathfix pkgconf
USE_LDCONFIG= ${PREFIX}/lib/linuxsampler
GNU_CONFIGURE= yes
+GNU_CONFIGURE_MANPREFIX= ${PREFIX}/share
CONFIGURE_ENV= HAVE_UNIX98=1
CONFIGURE_ARGS= --disable-arts-driver
-CXXFLAGS+= -I${LOCALBASE}/include/dssi
-
INSTALL_TARGET= install-strip
OPTIONS_DEFINE= JACK ALSA
@@ -43,6 +39,8 @@ ALSA_BROKEN= error: unknown type name 'snd_pcm_t'
JACK_LIB_DEPENDS= libjack.so:audio/jack
JACK_CONFIGURE_ENABLE= jack-driver
+CONFLICTS_BUILD= dssi # DSSI is a no-longer-maintained interface to obsolete LADSPA plugins - no need to pull DSSI and LADSPA into dependencies
+
post-patch:
@${REINPLACE_CMD} -e \
's|CXX_CPU_SWITCH=.*|CXX_CPU_SWITCH=|g ; \