aboutsummaryrefslogtreecommitdiff
path: root/audio/midiomatic-lv2/files/patch-Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'audio/midiomatic-lv2/files/patch-Makefile')
-rw-r--r--audio/midiomatic-lv2/files/patch-Makefile30
1 files changed, 30 insertions, 0 deletions
diff --git a/audio/midiomatic-lv2/files/patch-Makefile b/audio/midiomatic-lv2/files/patch-Makefile
new file mode 100644
index 000000000000..0bc4c76058ec
--- /dev/null
+++ b/audio/midiomatic-lv2/files/patch-Makefile
@@ -0,0 +1,30 @@
+- workaround for https://github.com/SpotlightKid/midiomatic/issues/3
+
+--- Makefile.orig 2022-03-19 23:05:49 UTC
++++ Makefile
+@@ -4,11 +4,11 @@
+ # Created by falkTX, Christopher Arndt, and Patrick Desaulniers
+ #
+
+-SHELL=/bin/bash
++SHELL=/bin/bash
+
+ -include dpf/Makefile.base.mk
+
+-all: libs plugins gen
++all: patch libs plugins gen
+
+ # --------------------------------------------------------------
+
+@@ -30,9 +30,9 @@ PLUGIN_BASE_URI = https://chrisarndt.de/plugins/
+ submodules:
+ -test -d .git && git submodule update --init --recursive
+
+-libs: submodules patch
++libs: patch
+
+-patch: submodules
++patch:
+ @-for p in $(DPF_PATCHES); do \
+ echo "Applying patch '$${p}'..."; \
+ patch -d dpf -r - -p1 -N -i ../patches/$${p}; \