aboutsummaryrefslogtreecommitdiff
path: root/audio/ocp/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'audio/ocp/Makefile')
-rw-r--r--audio/ocp/Makefile67
1 files changed, 37 insertions, 30 deletions
diff --git a/audio/ocp/Makefile b/audio/ocp/Makefile
index e540ee957de7..945f633041d0 100644
--- a/audio/ocp/Makefile
+++ b/audio/ocp/Makefile
@@ -1,14 +1,12 @@
-# Created by: Emanuel Haupt <ehaupt@critical.ch>
-
PORTNAME= ocp
-PORTVERSION= 0.2.90
-PORTREVISION= 1
+PORTVERSION= 0.2.107
PORTEPOCH= 1
CATEGORIES= audio
-MASTER_SITES= https://github.com/mywave82/opencubicplayer/releases/download/v${PORTVERSION}/
+MASTER_SITES= https://stian.cubic.org/ocp/
MAINTAINER= ehaupt@FreeBSD.org
COMMENT= Legendary Open Cubic Player
+WWW= https://stian.cubic.org/project-ocp.php
LICENSE= GPLv2+
LICENSE_FILE= ${WRKSRC}/COPYING
@@ -16,20 +14,24 @@ LICENSE_FILE= ${WRKSRC}/COPYING
ONLY_FOR_ARCHS= amd64 i386 powerpc powerpc64 powerpc64le
BUILD_DEPENDS= xa65:devel/xa65
-LIB_DEPENDS= libid3tag.so:audio/libid3tag \
+LIB_DEPENDS= libancient.so:archivers/ancient \
+ libcjson.so:devel/libcjson \
+ libdiscid.so:audio/libdiscid \
+ libid3tag.so:audio/libid3tag \
libmad.so:audio/libmad \
libogg.so:audio/libogg \
+ libpng.so:graphics/png \
libvorbis.so:audio/libvorbis
-USES= compiler:c11 dos2unix gmake gnome iconv localbase:ldflags \
- makeinfo ncurses pkgconfig tar:bz2
-
-INSTALLS_ICONS= yes
+USES= compiler:c11 dos2unix gmake gnome iconv jpeg localbase:ldflags \
+ makeinfo ncurses pkgconfig shared-mime-info tar:xz
GNU_CONFIGURE= yes
+GNU_CONFIGURE_MANPREFIX= ${PREFIX}/share
CONFIGURE_ARGS= --libdir=${PREFIX}/lib \
--with-dir-suffix="" \
- --without-sdl
+ --without-sdl \
+ --without-update-desktop-database
CONFIGURE_ENV= SHARED_FLAGS="${LDFLAGS} -shared" \
XA=${PREFIX}/bin/xa65
@@ -37,13 +39,16 @@ MAKE_JOBS_UNSAFE= yes
LDFLAGS_i386= -Wl,-z,notext
+CONFLICTS_INSTALL= alliance # man/man1/ocp.1.gz
+
INFO= ocp
-OPTIONS_DEFINE= ADPLUG ALSA DOCS FLAC MIDI OSS SDL X11
-OPTIONS_DEFAULT= ADPLUG ALSA FLAC MIDI OSS SDL X11
+OPTIONS_DEFINE= ADPLUG ALSA DOCS FLAC GME MIDI OSS SDL X11
+OPTIONS_DEFAULT= ADPLUG ALSA FLAC GME MIDI OSS SDL X11
OPTIONS_SUB= yes
ADPLUG_DESC= adplug support
+GME_DESC= libgme support for additional video game music support
MIDI_DESC= timidity support
ADPLUG_LIB_DEPENDS= libadplug.so:audio/libadplug \
@@ -56,29 +61,31 @@ ALSA_CONFIGURE_WITH= alsa
FLAC_LIB_DEPENDS= libFLAC.so:audio/flac
FLAC_CONFIGURE_WITH= flac
+GME_LIB_DEPENDS= libgme.so:audio/libgme
+GME_CONFIGURE_WITH= libgme
+
MIDI_RUN_DEPENDS= eawpats>0:audio/eawpats
OSS_CONFIGURE_WITH= oss
SDL_IMPLIES= X11
-SDL_BUILD_DEPENDS= ${LOCALBASE}/share/fonts/gnu-unifont-ttf/unifont.ttf:x11-fonts/gnu-unifont-ttf
-SDL_LIB_DEPENDS= libfreetype.so:print/freetype2 \
- libpng.so:graphics/png
-SDL_RUN_DEPENDS= ${LOCALBASE}/share/fonts/gnu-unifont-ttf/unifont.ttf:x11-fonts/gnu-unifont-ttf
-SDL_USES= desktop-file-utils jpeg sdl
+SDL_BUILD_DEPENDS= ${LOCALBASE}/share/fonts/gnu-unifont-otf/unifont.otf:x11-fonts/gnu-unifont-otf
+SDL_LIB_DEPENDS= libfreetype.so:print/freetype2
+SDL_RUN_DEPENDS= ${LOCALBASE}/share/fonts/gnu-unifont-otf/unifont.otf:x11-fonts/gnu-unifont-otf
+SDL_USES= desktop-file-utils sdl
SDL_USE= SDL=sdl2
SDL_CONFIGURE_WITH= sdl2 \
- unifontdir=${LOCALBASE}/share/fonts/gnu-unifont-ttf
+ unifontdir=${LOCALBASE}/share/fonts/gnu-unifont-otf
SDL_PLIST_SUB= DESKTOP=''
SDL_PLIST_SUB_OFF= DESKTOP='@comment '
-X11_BUILD_DEPENDS= ${LOCALBASE}/share/fonts/gnu-unifont-ttf/unifont.ttf:x11-fonts/gnu-unifont-ttf
-X11_LIB_DEPENDS= libfreetype.so:print/freetype2 \
- libpng.so:graphics/png
-X11_RUN_DEPENDS= ${LOCALBASE}/share/fonts/gnu-unifont-ttf/unifont.ttf:x11-fonts/gnu-unifont-ttf
-X11_USES= desktop-file-utils jpeg xorg
+X11_BUILD_DEPENDS= ${LOCALBASE}/share/fonts/gnu-unifont-otf/unifont.otf:x11-fonts/gnu-unifont-otf
+X11_LIB_DEPENDS= libfreetype.so:print/freetype2
+X11_RUN_DEPENDS= ${LOCALBASE}/share/fonts/gnu-unifont-otf/unifont.otf:x11-fonts/gnu-unifont-otf
+X11_USES= desktop-file-utils xorg
X11_USE= XORG=x11,xext,xpm,xxf86dga,xxf86vm
-X11_CONFIGURE_WITH= unifontdir=${LOCALBASE}/share/fonts/gnu-unifont-ttf x11
+X11_CONFIGURE_WITH= unifontdir-otf=${LOCALBASE}/share/fonts/gnu-unifont-otf \
+ x11
X11_PLIST_SUB= DESKTOP='' \
XORG=''
X11_PLIST_SUB_OFF= DESKTOP='@comment ' \
@@ -86,15 +93,15 @@ X11_PLIST_SUB_OFF= DESKTOP='@comment ' \
TIMIDITY_CFG= ${LOCALBASE}/share/timidity/timidity.cfg
-post-patch-SDL-off:
- @${REINPLACE_CMD} -E '/(LIBJPEG|LIBPNG_LIBS)/d' ${WRKSRC}/Rules.make.in
+.include <bsd.port.pre.mk>
-post-patch-X11-off:
- @${REINPLACE_CMD} -E '/(LIBJPEG|LIBPNG_LIBS)/d' ${WRKSRC}/Rules.make.in
+.if ${COMPILER_TYPE} == clang && ${COMPILER_VERSION} >= 160
+CFLAGS+= -Wno-error=incompatible-function-pointer-types
+.endif
post-install:
@${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/ocp
@${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/ocp/*.so
@${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/ocp/autoload/*.so
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>