aboutsummaryrefslogtreecommitdiff
path: root/audio/picard-plugins/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'audio/picard-plugins/Makefile')
-rw-r--r--audio/picard-plugins/Makefile21
1 files changed, 10 insertions, 11 deletions
diff --git a/audio/picard-plugins/Makefile b/audio/picard-plugins/Makefile
index 64407ccb431f..5a29a5492c22 100644
--- a/audio/picard-plugins/Makefile
+++ b/audio/picard-plugins/Makefile
@@ -1,18 +1,19 @@
PORTNAME= picard-plugins
-PORTVERSION= 2.0.20220607
+PORTVERSION= 2.0.20240123
CATEGORIES= audio python
MAINTAINER= jhale@FreeBSD.org
COMMENT= Plugins for Picard tagger
+WWW= https://picard.musicbrainz.org/plugins/
LICENSE= GPLv2+ GPLv3+ MIT WTFPL
LICENSE_COMB= multi
-USES= python:3.7+
+USES= python
USE_GITHUB= yes
GH_ACCOUNT= metabrainz
-GH_TAGNAME= ed8d64c
+GH_TAGNAME= 8b690ab
PORTSCOUT= limit:^2\.
@@ -21,9 +22,7 @@ NO_ARCH= yes
BUILD_WRKSRC= ${WRKSRC}/build
PLUGINSDIR= ${PYTHON_SITELIBDIR}/picard/plugins
-OPTIONS_DEFINE= BPM DOCS MOODBAR
-OPTIONS_GROUP= REPLAYGAIN
-OPTIONS_GROUP_REPLAYGAIN= FLAC MP3 VORBIS WAVPACK
+OPTIONS_DEFINE= BPM DOCS MOODBAR REPLAYGAIN2
OPTIONS_SUB= yes
BPM_DESC= Beats per minute
@@ -35,11 +34,11 @@ BPM_VARS= PKGMESSAGE+=${.CURDIR}/pkg-message.bmp
MOODBAR_DESC= Generate moodbar files
MOODBAR_RUN_DEPENDS= moodbar:audio/moodbar
-REPLAYGAIN_DESC= ReplayGain audio normalization
-FLAC_RUN_DEPENDS= metaflac:audio/flac
-MP3_RUN_DEPENDS= mp3gain:audio/mp3gain
-VORBIS_RUN_DEPENDS= vorbisgain:audio/vorbisgain
-WAVPACK_RUN_DEPENDS= wvgain:audio/wavpack
+REPLAYGAIN2_DESC= ReplayGain 2.0 audio normalization
+REPLAYGAIN2_RUN_DEPENDS= rsgain:audio/rsgain
+
+post-patch:
+ ${RM} -rf ${WRKSRC}/plugins/haikuattrs
do-build:
# Plugins that include a separate UI (those with an __init__.py) must