aboutsummaryrefslogtreecommitdiff
path: root/audio/polyphone/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'audio/polyphone/Makefile')
-rw-r--r--audio/polyphone/Makefile12
1 files changed, 5 insertions, 7 deletions
diff --git a/audio/polyphone/Makefile b/audio/polyphone/Makefile
index 55a33ec83e15..a22c4f9a019b 100644
--- a/audio/polyphone/Makefile
+++ b/audio/polyphone/Makefile
@@ -1,10 +1,11 @@
PORTNAME= polyphone
-DISTVERSION= 2.2.0.20210109
-PORTREVISION= 2
+DISTVERSION= 2.3.0
+PORTREVISION= 6
CATEGORIES= audio
MAINTAINER= yuri@FreeBSD.org
COMMENT= Graphical user interface for editing soundfont (sf2 and sfz) files
+WWW= https://www.polyphone-soundfonts.com/
LICENSE= GPLv3
LICENSE_FILE= ${WRKSRC}/../LICENSE.txt
@@ -13,7 +14,7 @@ LIB_DEPENDS= libFLAC.so:audio/flac \
libjack.so:audio/jack \
libogg.so:audio/libogg \
libportaudio.so:audio/portaudio \
- libQCustomPlot-qt5.so:graphics/qcustomplot-qt5 \
+ libQCustomPlot-qt5.so:graphics/qcustomplot@qt5 \
librtmidi.so:audio/rtmidi \
libstk.so:audio/stk \
libvorbisfile.so:audio/libvorbis
@@ -23,21 +24,18 @@ DOS2UNIX_FILES= polyphone.pro \
editor/graphics/graphiquefourier.cpp \
editor/tree/treeitemdelegate.cpp
USE_GL= gl
-USE_QT= core concurrent gui network printsupport svg widgets buildtools_build linguisttools_build qmake_build
+USE_QT= core concurrent gui network printsupport svg widgets buildtools:build linguisttools:build qmake:build
USE_GNOME= glib20
USE_CXXSTD= c++11
USE_GITHUB= yes
GH_ACCOUNT= davy7125
-GH_TAGNAME= 75a5e88
CXXFLAGS+= -D__UNIX_JACK__
LIBS+= -lssl -lcrypto
WRKSRC_SUBDIR= sources
-INSTALLS_ICONS= yes
-
post-extract: # unbundle
@${RM} -r ${WRKSRC}/lib/_option_qcustomplot ${WRKSRC}/lib/_option_rtmidi ${WRKSRC}/lib/_option_stk