aboutsummaryrefslogtreecommitdiff
path: root/audio/py-pyaudio/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'audio/py-pyaudio/Makefile')
-rw-r--r--audio/py-pyaudio/Makefile25
1 files changed, 12 insertions, 13 deletions
diff --git a/audio/py-pyaudio/Makefile b/audio/py-pyaudio/Makefile
index d81fbc799c52..50cb73ec7525 100644
--- a/audio/py-pyaudio/Makefile
+++ b/audio/py-pyaudio/Makefile
@@ -1,28 +1,28 @@
-# Created by: Jaap Akkerhuis <jaap@NLnetLabs.nl>
-
PORTNAME= pyaudio
-PORTVERSION= 0.2.11
-PORTREVISION= 2
+PORTVERSION= 0.2.13
CATEGORIES= audio python
-MASTER_SITES= CHEESESHOP
+MASTER_SITES= PYPI
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
DISTNAME= PyAudio-${PORTVERSION}
MAINTAINER= jaap@NLnetLabs.nl
COMMENT= Portaudio toolkit bindings for Python
+WWW= https://people.csail.mit.edu/hubert/pyaudio/
LICENSE= MIT
LIB_DEPENDS= libportaudio.so:audio/portaudio
-USES= python:3.6+ gmake
-USE_PYTHON= distutils concurrent autoplist
+USES= gmake python
+USE_PYTHON= autoplist concurrent distutils
MAKE_ENV= PYTHON=${PYTHON_CMD} \
SPHINX=sphinx-build-${PYTHON_VER}
-PORTDOCS= *
+
WRKSRC= ${WRKDIR}/PyAudio-${PORTVERSION}
+PORTDOCS= *
+
OPTIONS_DEFINE= DOCS
DOCS_BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}sphinx>=0,1:textproc/py-sphinx@${PY_FLAVOR}
@@ -32,12 +32,11 @@ post-patch:
${WRKSRC}/setup.py
post-build-DOCS-on:
- (cd ${BUILD_WRKSRC} && ${DO_MAKE_BUILD} docs)
+ (cd ${BUILD_WRKSRC} && \
+ ${DO_MAKE_BUILD} docs)
post-install-DOCS-on:
- (cd ${WRKSRC}/docs && ${COPYTREE_SHARE} . ${STAGEDIR}${DOCSDIR} "! -name .buildinfo -and ! -path *doctrees*")
-
-post-install:
- @${STRIP_CMD} ${STAGEDIR}${PYTHON_SITELIBDIR}/_portaudio*.so
+ (cd ${WRKSRC}/docs && \
+ ${COPYTREE_SHARE} . ${STAGEDIR}${DOCSDIR} "! -name .buildinfo -and ! -path *doctrees*")
.include <bsd.port.mk>