aboutsummaryrefslogtreecommitdiff
path: root/audio/py-pyaudio/files/patch-setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'audio/py-pyaudio/files/patch-setup.py')
-rw-r--r--audio/py-pyaudio/files/patch-setup.py24
1 files changed, 12 insertions, 12 deletions
diff --git a/audio/py-pyaudio/files/patch-setup.py b/audio/py-pyaudio/files/patch-setup.py
index 37be2151de14..872eba21d658 100644
--- a/audio/py-pyaudio/files/patch-setup.py
+++ b/audio/py-pyaudio/files/patch-setup.py
@@ -1,15 +1,15 @@
---- setup.py.orig 2015-10-19 05:48:12 UTC
+--- setup.py.orig 2022-07-19 03:53:30 UTC
+++ setup.py
-@@ -63,6 +63,12 @@ extra_link_args = []
- scripts = []
- defines = []
+@@ -56,6 +56,12 @@ def setup_extension():
+ extra_link_args = []
+ defines = []
-+if sys.platform.startswith('dragonfly') or \
-+ sys.platform.startswith('freebsd'):
-+ include_dirs = ['%%LOCALBASE%%/include/']
-+ external_libraries = []
-+ extra_link_args = ['%%LOCALBASE%%/lib/libportaudio.so']
++ if sys.platform.startswith('dragonfly') or \
++ sys.platform.startswith('freebsd'):
++ include_dirs = ['%%LOCALBASE%%/include/']
++ external_libraries = []
++ extra_link_args = ['%%LOCALBASE%%/lib/libportaudio.so']
+
- if sys.platform == 'darwin':
- defines += [('MACOSX', '1')]
- if mac_sysroot_path:
+ if sys.platform == 'darwin':
+ # Support only dynamic linking with portaudio, since the supported path
+ # is to install portaudio using a package manager (e.g., Homebrew).