aboutsummaryrefslogtreecommitdiff
path: root/audio/rosegarden/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'audio/rosegarden/Makefile')
-rw-r--r--audio/rosegarden/Makefile13
1 files changed, 5 insertions, 8 deletions
diff --git a/audio/rosegarden/Makefile b/audio/rosegarden/Makefile
index 43d1458f229d..d9f666187f70 100644
--- a/audio/rosegarden/Makefile
+++ b/audio/rosegarden/Makefile
@@ -1,13 +1,12 @@
-# Created by: shanee@augusta.de
-
PORTNAME= rosegarden
-PORTVERSION= 20.06
-PORTREVISION= 2
+DISTVERSION= 22.12.1
+PORTREVISION= 1
CATEGORIES= audio
-MASTER_SITES= SF
+MASTER_SITES= https://sourceforge.net/projects/${PORTNAME}/files/${PORTNAME}/${DISTVERSION:R}/
MAINTAINER= adridg@FreeBSD.org
COMMENT= General purpose music editor and sequencer suite
+WWW= https://www.rosegardenmusic.com/
LICENSE= GPLv2+
LICENSE_FILE= ${WRKSRC}/COPYING
@@ -31,7 +30,7 @@ USES= alias cmake compiler:c++11-lib desktop-file-utils \
localbase:ldflags pkgconfig shared-mime-info tar:bzip2 \
qt:5 xorg
USE_QT= core gui network printsupport testlib widgets xml \
- buildtools_build linguisttools_build qmake_build
+ buildtools:build linguisttools:build qmake:build
USE_XORG= ice sm x11 xext
OPTIONS_DEFINE= LIRC
@@ -39,6 +38,4 @@ OPTIONS_DEFINE= LIRC
LIRC_LIB_DEPENDS= liblirc_client.so:comms/lirc
LIRC_CMAKE_ON= -DENABLE_LIRC:BOOL=ON
-CMAKE_ON= USE_QT5
-
.include <bsd.port.mk>