aboutsummaryrefslogtreecommitdiff
path: root/audio/spectmorph/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'audio/spectmorph/Makefile')
-rw-r--r--audio/spectmorph/Makefile21
1 files changed, 16 insertions, 5 deletions
diff --git a/audio/spectmorph/Makefile b/audio/spectmorph/Makefile
index 898f78a37d3f..273db6230c2f 100644
--- a/audio/spectmorph/Makefile
+++ b/audio/spectmorph/Makefile
@@ -1,23 +1,27 @@
PORTNAME= spectmorph
-DISTVERSION= 0.5.2
-PORTREVISION= 2
+DISTVERSION= 0.6.1
+PORTREVISION= 1
CATEGORIES= audio
-MASTER_SITES= https://spectmorph.org/files/releases/
+MASTER_SITES= https://github.com/swesterfeld/spectmorph/releases/download/${DISTVERSION}/
MAINTAINER= yuri@FreeBSD.org
COMMENT= Analyze and combine samples of musical instruments
+WWW= https://spectmorph.org/
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/COPYING
+BROKEN_aarch64= error: unknown type name '__m128'
+BROKEN_armv7= error: unknown type name '__m128'
+
BUILD_DEPENDS= fftw3>0:math/fftw3
LIB_DEPENDS= libao.so:audio/libao \
libfftw3f.so:math/fftw3-float \
libfreetype.so:print/freetype2 \
libsndfile.so:audio/libsndfile
-USES= autoreconf desktop-file-utils gettext-runtime gl gmake gnome libtool pkgconfig python:run qt:5 shebangfix tar:bz2 xorg
-USE_QT= core gui widgets buildtools_build
+USES= autoreconf desktop-file-utils gettext gl gmake gnome iconv libtool pkgconfig python:run qt:5 shebangfix tar:bz2 xorg
+USE_QT= core gui widgets buildtools:build
USE_GNOME= cairo glib20
USE_GL= gl
USE_XORG= x11
@@ -26,6 +30,7 @@ USE_LDCONFIG= yes
SHEBANG_FILES= tools/sminstbuilder.in
GNU_CONFIGURE= yes
+GNU_CONFIGURE_MANPREFIX= ${PREFIX}/share
LDFLAGS+= -L${LOCALBASE}/lib -lfftw3f_threads
@@ -42,4 +47,10 @@ LV2_DESC= Build the LV2 plugin
LV2_CONFIGURE_WITH= lv2
LV2_BUILD_DEPENDS= lv2>0:audio/lv2
+post-install:
+ @cd ${STAGEDIR}${PREFIX} && ${STRIP_CMD} \
+ lib/vst/spectmorph_vst.so \
+ lib/clap/SpectMorph.clap \
+ lib/lv2/spectmorph.lv2/spectmorph_lv2.so
+
.include <bsd.port.mk>