aboutsummaryrefslogtreecommitdiff
path: root/audio/speex-devel/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'audio/speex-devel/Makefile')
-rw-r--r--audio/speex-devel/Makefile45
1 files changed, 0 insertions, 45 deletions
diff --git a/audio/speex-devel/Makefile b/audio/speex-devel/Makefile
deleted file mode 100644
index 4bd355ffca1d..000000000000
--- a/audio/speex-devel/Makefile
+++ /dev/null
@@ -1,45 +0,0 @@
-# ex:ts=8
-# Ports collection makefile for: Speex
-# Date created: Jul 30, 2002
-# Whom: ijliao
-#
-# $FreeBSD$
-#
-
-PORTNAME= speex
-PORTVERSION= 1.0.r2
-PORTEPOCH= 1
-CATEGORIES= audio
-MASTER_SITES= http://www.speex.org/download/
-DISTNAME= ${PORTNAME}-${PORTVERSION:S/.r/rc/}
-
-MAINTAINER= ports@FreeBSD.org
-COMMENT= An open-source patent-free voice codec
-
-LIB_DEPENDS= ogg.4:${PORTSDIR}/audio/libogg
-
-USE_REINPLACE= yes
-USE_LIBTOOL= yes
-LIBTOOLFLAGS= --disable-ltlibs --release-ignore
-CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
-CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
-INSTALLS_SHLIB= yes
-
-MAN1= speexdec.1 speexenc.1
-
-CPPFLAGS= -I${LOCALBASE}/include
-LDFLAGS= -L${LOCALBASE}/lib
-
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} < 500041
-LIB_DEPENDS+= gnugetopt.1:${PORTSDIR}/devel/libgnugetopt
-LDFLAGS+= -lgnugetopt
-.endif
-
-post-patch:
- @${FIND} ${WRKSRC} -name "Makefile.in" | ${XARGS} ${REINPLACE_CMD} -e \
- 's|doc win32|win32|g ; \
- s|^mandir =.*$$|mandir = @mandir@|g'
-
-.include <bsd.port.post.mk>