aboutsummaryrefslogtreecommitdiff
path: root/audio/surge-synthesizer-lv2/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'audio/surge-synthesizer-lv2/Makefile')
-rw-r--r--audio/surge-synthesizer-lv2/Makefile12
1 files changed, 11 insertions, 1 deletions
diff --git a/audio/surge-synthesizer-lv2/Makefile b/audio/surge-synthesizer-lv2/Makefile
index 4086cc554a5e..66fc884e3538 100644
--- a/audio/surge-synthesizer-lv2/Makefile
+++ b/audio/surge-synthesizer-lv2/Makefile
@@ -1,15 +1,25 @@
PORTNAME= surge-synthesizer
DISTVERSIONPREFIX= release_
DISTVERSION= 1.9.0
+PORTREVISION= 1
CATEGORIES= audio
PKGNAMESUFFIX= -lv2
MAINTAINER= yuri@FreeBSD.org
COMMENT= Surge Synthesizer LV2 and VST plug-in
+WWW= https://surge-synthesizer.github.io/
LICENSE= GPLv3
LICENSE_FILE= ${WRKSRC}/LICENSE
+BROKEN_aarch64= error: use of undeclared identifier '__builtin_ia32_packssdw'
+BROKEN_armv6= emmintrin.h:14:2: error: "This header is only meant to be used on x86 and x64, see https://github.com/surge-synthesizer/surge/issues/6418
+BROKEN_armv7= emmintrin.h:14:2: error: "This header is only meant to be used on x86 and x64, see https://github.com/surge-synthesizer/surge/issues/6418
+BROKEN_powerpc= compilation fails due to a problem in the clang header, see https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=276794
+BROKEN_powerpc64= compilation fails due to a problem in the clang header, see https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=276794
+BROKEN_powerpc64le= compilation fails due to a problem in the clang header, see https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=276794
+BROKEN_riscv64= error: functions that differ only in their return type cannot be overloaded - simde-related, see https://github.com/simd-everywhere/simde/issues/962
+
BUILD_DEPENDS= lv2>0:audio/lv2 \
${LOCALBASE}/include/nanosvg.h:graphics/nanosvg \
${LOCALBASE}/include/simde/simde-common.h:devel/simde \
@@ -50,7 +60,7 @@ LDFLAGS+= -lexecinfo
BINARY_ALIAS= python=${PYTHON_CMD} # git=false
-PORTSCOUT= limit:^\d+\. # prevent alpha-numeric strings
+PORTSCOUT= ignore:1
post-patch:
@${REINPLACE_CMD} -e 's|"/usr/share/Surge/"|"${DATADIR}/"|' ${WRKSRC}/src/common/SurgeStorage.cpp