aboutsummaryrefslogtreecommitdiff
path: root/audio/surge-synthesizer-xt-lv2/files/patch-src_CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'audio/surge-synthesizer-xt-lv2/files/patch-src_CMakeLists.txt')
-rw-r--r--audio/surge-synthesizer-xt-lv2/files/patch-src_CMakeLists.txt11
1 files changed, 11 insertions, 0 deletions
diff --git a/audio/surge-synthesizer-xt-lv2/files/patch-src_CMakeLists.txt b/audio/surge-synthesizer-xt-lv2/files/patch-src_CMakeLists.txt
new file mode 100644
index 000000000000..b41bd49ded01
--- /dev/null
+++ b/audio/surge-synthesizer-xt-lv2/files/patch-src_CMakeLists.txt
@@ -0,0 +1,11 @@
+--- src/CMakeLists.txt.orig 2022-03-28 01:18:40 UTC
++++ src/CMakeLists.txt
+@@ -44,7 +44,7 @@ target_compile_definitions(surge-juce INTERFACE
+ JUCE_CATCH_UNHANDLED_EXCEPTIONS=0
+ )
+
+-set(SURGE_JUCE_FORMATS VST3)
++set(SURGE_JUCE_FORMATS Standalone)
+
+ if (CLAP_JUCE_EXTENSIONS_ROOT)
+ add_subdirectory(${CLAP_JUCE_EXTENSIONS_ROOT} clap-extensions)