aboutsummaryrefslogtreecommitdiff
path: root/audio/welle.io/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'audio/welle.io/Makefile')
-rw-r--r--audio/welle.io/Makefile37
1 files changed, 19 insertions, 18 deletions
diff --git a/audio/welle.io/Makefile b/audio/welle.io/Makefile
index 44715ff73bdd..7a35b96e2646 100644
--- a/audio/welle.io/Makefile
+++ b/audio/welle.io/Makefile
@@ -1,9 +1,11 @@
PORTNAME= welle.io
-DISTVERSION= 2.3
+DISTVERSION= 2.4
+PORTREVISION= 2
CATEGORIES= audio hamradio
MAINTAINER= nsonack@outlook.com
COMMENT= SDR DAB/DAB+ Receiver
+WWW= https://www.welle.io/
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/COPYING
@@ -15,38 +17,37 @@ LIB_DEPENDS= libasound.so:audio/alsa-lib \
RUN_DEPENDS= ${LOCALBASE}/lib/alsa-lib/libasound_module_pcm_oss.so:audio/alsa-plugins
USES= cmake compiler:c++11-lang pkgconfig qt:5
-USE_QT= charts core declarative gui multimedia network quickcontrols2 \
- widgets buildtools_build qmake_build
-
USE_GITHUB= yes
GH_ACCOUNT= AlbrechtL
-GH_TAGNAME= 66675c9a4160c644a5ade5bf7a0cd0647647f33c
+GH_TAGNAME= 0aacf578d77d79212483cd6fce436fb66523f63f
+USE_QT= charts core dbus declarative gui multimedia network \
+ quickcontrols2 widgets buildtools:build qmake:build
OPTIONS_DEFINE= AIRSPY CLI FFTW RTLSDR SOAPY
OPTIONS_DEFAULT= FFTW RTLSDR
-RTLSDR_DESC= RTL-SDR support
AIRSPY_DESC= AirSpy support
-SOAPY_DESC= SoapySDR support
-FFTW_DESC= Use FFTW3 instead of KISSFFT
CLI_DESC= Build the welle-cli tool
+FFTW_DESC= Use FFTW3 instead of KISSFFT
+RTLSDR_DESC= RTL-SDR support
+SOAPY_DESC= SoapySDR support
-RTLSDR_LIB_DEPENDS= librtlsdr.so:comms/rtl-sdr
-RTLSDR_CMAKE_BOOL= RTLSDR
-
-FFTW_CMAKE_BOOL_OFF= KISS_FFT
-FFTW_LIB_DEPENDS= libfftw3f.so:math/fftw3-float
-FFTW_BUILD_DEPENDS= fftw3>=0:math/fftw3
+AIRSPY_LIB_DEPENDS= libairspy.so:comms/airspy
+AIRSPY_CMAKE_BOOL= AIRSPY
CLI_CMAKE_BOOL= BUILD_WELLE_CLI
CLI_PLIST_FILES= bin/welle-cli \
share/welle-io/html/index.html \
share/welle-io/html/index.js
-SOAPY_CMAKE_BOOL= SOAPYSDR
-SOAPY_LIB_DEPENDS= libSoapySDR.so:misc/soapysdr
+FFTW_BUILD_DEPENDS= fftw3>=0:math/fftw3
+FFTW_LIB_DEPENDS= libfftw3f.so:math/fftw3-float
+FFTW_CMAKE_BOOL_OFF= KISS_FFT
-AIRSPY_CMAKE_BOOL= AIRSPY
-AIRSPY_LIB_DEPENDS= libairspy.so:comms/airspy
+RTLSDR_LIB_DEPENDS= librtlsdr.so:comms/rtl-sdr
+RTLSDR_CMAKE_BOOL= RTLSDR
+
+SOAPY_LIB_DEPENDS= libSoapySDR.so:misc/soapysdr
+SOAPY_CMAKE_BOOL= SOAPYSDR
.include <bsd.port.mk>