aboutsummaryrefslogtreecommitdiff
path: root/audio/x42-plugins-lv2/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'audio/x42-plugins-lv2/Makefile')
-rw-r--r--audio/x42-plugins-lv2/Makefile17
1 files changed, 11 insertions, 6 deletions
diff --git a/audio/x42-plugins-lv2/Makefile b/audio/x42-plugins-lv2/Makefile
index 6a199f0d7e76..8d7caacd0bb9 100644
--- a/audio/x42-plugins-lv2/Makefile
+++ b/audio/x42-plugins-lv2/Makefile
@@ -1,7 +1,5 @@
-# Created by: Yuri Victorovich <yuri@rawbw.com>
-
PORTNAME= x42-plugins
-DISTVERSION= 20210714 # the version is published here: http://gareus.org/misc/x42-plugins.php
+DISTVERSION= 20230706 # the version is published here: http://gareus.org/misc/x42-plugins.php
PORTREVISION= 1
CATEGORIES= audio
MASTER_SITES= http://gareus.org/misc/x42-plugins/
@@ -10,9 +8,12 @@ DISTFILES= ${DISTNAME}${EXTRACT_SUFX} # only to allow USE_GITHUB=nodefault for z
MAINTAINER= yuri@FreeBSD.org
COMMENT= Collection of LV2 plugins (submodules)
+WWW= https://github.com/x42/x42-plugins/
LICENSE= GPLv2
+BROKEN_i386= compilation fails: unsupported option '--fast-math'; did you mean '-ffast-math', reported to the author on 2022-11-06
+
BUILD_DEPENDS= lv2>0:audio/lv2 \
${LOCALBASE}/include/fftw3.h:math/fftw3 \
bash:shells/bash
@@ -27,16 +28,20 @@ LIB_DEPENDS= libfftw3f.so:math/fftw3-float \
USES= compiler:c++11-lang gl gmake gnome localbase pkgconfig tar:xz \
shebangfix xorg
-USE_GITHUB= nodefault
-GH_TUPLE= x42:convoLV2:ff291a3:x/convoLV2zita4
USE_GNOME= glib20 pango cairo
USE_XORG= x11
USE_GL= glu gl
-MAKE_ENV= BUILDOPENGL=yes BUILDGTK=no LV2DIR=${PREFIX}/lib/lv2 MANDIR=${PREFIX}/man/man1
+
+USE_GITHUB= nodefault
+GH_TUPLE= x42:convoLV2:ff291a3:x/convoLV2zita4
+
+MAKE_ENV= BUILDOPENGL=yes BUILDGTK=no LV2DIR=${PREFIX}/lib/lv2 MANDIR=${PREFIX}/share/man/man1
SHEBANG_FILES= stepseq.lv2/gridgen.sh
CXXFLAGS+= -std=c++98
+CONFLICTS_INSTALL= phaserotate-lv2 # lib/lv2/phaserotate.lv2/phaserotate.so
+
OPTIONS_DEFINE_amd64= SSE
OPTIONS_DEFINE_i386= SSE
OPTIONS_DEFAULT_amd64= SSE