aboutsummaryrefslogtreecommitdiff
path: root/audio/xfce4-pulseaudio-plugin/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'audio/xfce4-pulseaudio-plugin/Makefile')
-rw-r--r--audio/xfce4-pulseaudio-plugin/Makefile17
1 files changed, 7 insertions, 10 deletions
diff --git a/audio/xfce4-pulseaudio-plugin/Makefile b/audio/xfce4-pulseaudio-plugin/Makefile
index 288cdd941aca..483270f0d13f 100644
--- a/audio/xfce4-pulseaudio-plugin/Makefile
+++ b/audio/xfce4-pulseaudio-plugin/Makefile
@@ -1,31 +1,28 @@
-# Created by: Olivier Duchateau
-
PORTNAME= xfce4-pulseaudio-plugin
-PORTVERSION= 0.4.3
-PORTREVISION= 1
+PORTVERSION= 0.4.8
+PORTREVISION= 2
CATEGORIES= audio xfce
MASTER_SITES= XFCE/panel-plugins
DIST_SUBDIR= xfce4
MAINTAINER= xfce@FreeBSD.org
COMMENT= Panel plugin for controlling PulseAudio mixer
+WWW= https://goodies.xfce.org/projects/panel-plugins/xfce4-pulseaudio-plugin
LICENSE= GPLv2
LIB_DEPENDS= libpulse-mainloop-glib.so:audio/pulseaudio \
- libdbus-1.so:devel/dbus \
- libdbus-glib-1.so:devel/dbus-glib \
- libnotify.so:devel/libnotify
+ libnotify.so:devel/libnotify \
+ libharfbuzz.so:print/harfbuzz
RUN_DEPENDS= pavucontrol>=2.0:audio/pavucontrol
USES= compiler:c11 gettext-tools gmake gnome libtool pkgconfig \
tar:bzip2 xfce xorg
-USE_GNOME= cairo glib20 gtk30 intltool libwnck3
-USE_XFCE= panel
+USE_GNOME= cairo gdkpixbuf2 glib20 gtk30 intltool libwnck3
+USE_XFCE= libexo panel xfconf
USE_XORG= x11
GNU_CONFIGURE= yes
-INSTALLS_ICONS= yes
INSTALL_TARGET= install-strip
CONFIGURE_ARGS=--with-mixer-command=${LOCALBASE}/bin/pavucontrol \