aboutsummaryrefslogtreecommitdiff
path: root/benchmarks/scimark4c/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'benchmarks/scimark4c/Makefile')
-rw-r--r--benchmarks/scimark4c/Makefile21
1 files changed, 21 insertions, 0 deletions
diff --git a/benchmarks/scimark4c/Makefile b/benchmarks/scimark4c/Makefile
new file mode 100644
index 000000000000..5c73f35cc7e8
--- /dev/null
+++ b/benchmarks/scimark4c/Makefile
@@ -0,0 +1,21 @@
+PORTNAME= scimark4c
+PORTVERSION= 4
+CATEGORIES= benchmarks
+MASTER_SITES= http://math.nist.gov/scimark2/
+DISTNAME= ${PORTNAME}
+
+MAINTAINER= thierry@FreeBSD.org
+COMMENT= ANSI C version of the SciMark2 benchmark
+WWW= https://math.nist.gov/scimark2/download_c.html
+
+LICENSE= PD
+
+USES= zip
+
+WRKSRC= ${WRKDIR}/${PORTNAME:C/4c/4/}
+PLIST_FILES= bin/scimark4
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/scimark4 ${STAGEDIR}${PREFIX}/bin
+
+.include <bsd.port.mk>