aboutsummaryrefslogtreecommitdiff
path: root/benchmarks/siege/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'benchmarks/siege/Makefile')
-rw-r--r--benchmarks/siege/Makefile19
1 files changed, 14 insertions, 5 deletions
diff --git a/benchmarks/siege/Makefile b/benchmarks/siege/Makefile
index 796583689851..8e49baf2534b 100644
--- a/benchmarks/siege/Makefile
+++ b/benchmarks/siege/Makefile
@@ -1,21 +1,30 @@
-# Created by: Mark Pulford <mark@kyne.com.au>
-
PORTNAME= siege
-PORTVERSION= 4.0.9
+PORTVERSION= 4.1.6
+PORTREVISION= 1
CATEGORIES= benchmarks www
MASTER_SITES= http://download.joedog.org/siege/ \
http://fossies.org/linux/www/
MAINTAINER= bofh@FreeBSD.org
COMMENT= HTTP regression testing and benchmarking utility
+WWW= https://www.joedog.org/JoeDog/Siege
LICENSE= GPLv2
USES= autoreconf libtool perl5 ssl
+
GNU_CONFIGURE= yes
+GNU_CONFIGURE_MANPREFIX=${PREFIX}/share
+CONFIGURE_ARGS= --disable-shared \
+ --sysconfdir=${ETCDIR} \
+ --with-ssl=${OPENSSLBASE}
CONFIGURE_ENV= PERL="${PERL}"
-CONFIGURE_ARGS= --with-ssl=${OPENSSLBASE} --disable-shared \
- --sysconfdir=${ETCDIR}
+
+.include <bsd.port.options.mk>
+
+.if ${OPSYS} == FreeBSD && ( ${OSVERSION} >= 1400079 || ( ${OSVERSION} >= 1302505 && ${OSVERSION} < 1400000 ))
+CFLAGS+= -Wno-error=int-conversion
+.endif
pre-configure:
@${RM} ${WRKSRC}/acinclude.m4