aboutsummaryrefslogtreecommitdiff
path: root/biology/cufflinks/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'biology/cufflinks/Makefile')
-rw-r--r--biology/cufflinks/Makefile8
1 files changed, 7 insertions, 1 deletions
diff --git a/biology/cufflinks/Makefile b/biology/cufflinks/Makefile
index 0de2dda73fec..a737f0a40204 100644
--- a/biology/cufflinks/Makefile
+++ b/biology/cufflinks/Makefile
@@ -1,7 +1,7 @@
PORTNAME= cufflinks
DISTVERSIONPREFIX= v
DISTVERSION= 2.2.1-89
-PORTREVISION= 2
+PORTREVISION= 8
DISTVERSIONSUFFIX= -gdc3b0cb
CATEGORIES= biology
@@ -10,6 +10,7 @@ PATCHFILES+= ea4671149f3054c773d99cea521db75bf7b0658f.patch:-p1 # https://github
MAINTAINER= yuri@FreeBSD.org
COMMENT= Cufflinks assembles transcripts, estimates their abundance, etc
+WWW= https://cole-trapnell-lab.github.io/cufflinks/
LICENSE= BSL
LICENSE_FILE= ${WRKSRC}/LICENSE
@@ -18,14 +19,19 @@ LIB_DEPENDS= libboost_system.so:devel/boost-libs \
libhts.so:biology/htslib
USES= autoreconf compiler:c++11-lang eigen:3 gmake python shebangfix
+
SHEBANG_FILES= src/cuffmerge
+
GNU_CONFIGURE= yes
+
USE_GITHUB= yes
GH_ACCOUNT= cole-trapnell-lab
CXXFLAGS+= -I${LOCALBASE}/include/eigen3
CFLAGS+= -I${LOCALBASE}/include/eigen3 # https://github.com/cole-trapnell-lab/cufflinks/issues/113
+CONFLICTS_INSTALL= gffread
+
PLIST_FILES= bin/compress_gtf \
bin/cuffcompare \
bin/cuffdiff \