aboutsummaryrefslogtreecommitdiff
path: root/biology/ncbi-blast+/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'biology/ncbi-blast+/Makefile')
-rw-r--r--biology/ncbi-blast+/Makefile22
1 files changed, 14 insertions, 8 deletions
diff --git a/biology/ncbi-blast+/Makefile b/biology/ncbi-blast+/Makefile
index 265779243d25..5e3ccea79b43 100644
--- a/biology/ncbi-blast+/Makefile
+++ b/biology/ncbi-blast+/Makefile
@@ -1,6 +1,6 @@
PORTNAME= ncbi-blast+
-DISTVERSION= 2.12.0
-PORTREVISION= 2
+DISTVERSION= 2.14.1
+PORTREVISION= 3
CATEGORIES= biology perl5 python
MASTER_SITES= https://ftp.ncbi.nlm.nih.gov/blast/executables/blast+/LATEST/ \
https://ftp.ncbi.nlm.nih.gov/blast/executables/blast+/${PORTVERSION}/
@@ -8,10 +8,14 @@ DISTNAME= ncbi-blast-${PORTVERSION}+-src
MAINTAINER= jwb@FreeBSD.org
COMMENT= NCBI implementation of Basic Local Alignment Search Tool
+WWW= https://blast.ncbi.nlm.nih.gov
LICENSE= PD
LICENSE_FILE= ${WRKSRC}/scripts/projects/blast/LICENSE
+ONLY_FOR_ARCHS= aarch64 amd64 powerpc64 powerpc64le riscv64
+ONLY_FOR_ARCHS_REASON= Requires 64-bit processor
+
LIB_DEPENDS= libpcre.so:devel/pcre \
liblmdb.so:databases/lmdb \
liblzo2.so:archivers/lzo2 \
@@ -28,11 +32,13 @@ LIB_DEPENDS= libpcre.so:devel/pcre \
libsqlite3.so:databases/sqlite3 \
libuv.so:devel/libuv \
libnghttp2.so:www/libnghttp2 \
- libgrpc.so:devel/grpc
+ libgrpc.so:devel/grpc \
+ libzstd.so:archivers/zstd \
+ libdw.so:devel/elfutils
RUN_DEPENDS= p5-List-MoreUtils>=0:lang/p5-List-MoreUtils \
p5-JSON>=0:converters/p5-JSON
-USES= compiler:c++14-lang gmake localbase:ldflags shebangfix perl5 python:3.6+
+USES= compiler:c++14-lang gmake localbase:ldflags shebangfix perl5 python
USE_LDCONFIG= yes
SHEBANG_FILES= src/app/blast/legacy_blast.pl \
@@ -52,6 +58,10 @@ CONFLICTS_INSTALL= ncbi-cxx-toolkit
WRKSRC_SUBDIR= c++
+.if !exists(/usr/include/omp.h)
+CONFIGURE_ARGS+= --without-openmp
+.endif
+
.include <bsd.port.pre.mk>
.if ${CHOSEN_COMPILER_TYPE} == gcc
@@ -59,10 +69,6 @@ WRKSRC_SUBDIR= c++
LDFLAGS+= -latomic # Only exists in gcc libs
.endif
-.if ${ARCH} == powerpc
-CONFIGURE_ARGS+= --without-openmp
-.endif
-
post-install:
@${RM} ${STAGEDIR}${PREFIX}/include/ncbi-tools++/*/*/.cvsignore.extra
@${RM} -rf ${STAGEDIR}${PREFIX}/lib/X11