aboutsummaryrefslogtreecommitdiff
path: root/biology/pooler/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'biology/pooler/Makefile')
-rw-r--r--biology/pooler/Makefile18
1 files changed, 12 insertions, 6 deletions
diff --git a/biology/pooler/Makefile b/biology/pooler/Makefile
index f674ed8d0e6f..7b530ceaa130 100644
--- a/biology/pooler/Makefile
+++ b/biology/pooler/Makefile
@@ -1,26 +1,32 @@
PORTNAME= pooler
DISTVERSIONPREFIX= v
-DISTVERSION= 1.78
+DISTVERSION= 1.88
+PORTREVISION= 1
CATEGORIES= biology
MAINTAINER= ssb22@cam.ac.uk
COMMENT= Optimise DNA sequencing primer-set combinations
+WWW= https://ssb22.user.srcf.net/pooler/
LICENSE= APACHE20
LICENSE_FILE= ${WRKDIR}/${GH_PROJECT}-${PORTVERSION}/LICENSE
-# Not needed on x86, aarch64, or ppc64-13.x
-# Might need gcc on 32-bit ARM/PPC
-USES= compiler:openmp
+USES= desktop-file-utils
USE_GITHUB= yes
GH_ACCOUNT= ssb22
GH_PROJECT= PrimerPooler
+INSTALL_TARGET= install-strip
+
WRKSRC_SUBDIR= pooler
+PLIST_FILES= bin/pooler share/man/man1/pooler.1.gz share/applications/pooler.desktop
+
+.if exists(/usr/include/omp.h)
CFLAGS+= -fopenmp
+.endif
-INSTALL_TARGET= install-strip
-PLIST_FILES= bin/pooler man/man1/pooler.1.gz share/applications/pooler.desktop
+post-patch:
+ ${REINPLACE_CMD} -e 's|man/man1|share/man/man1|g' ${WRKSRC}/Makefile
.include <bsd.port.mk>