aboutsummaryrefslogtreecommitdiff
path: root/biology/ugene/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'biology/ugene/Makefile')
-rw-r--r--biology/ugene/Makefile28
1 files changed, 12 insertions, 16 deletions
diff --git a/biology/ugene/Makefile b/biology/ugene/Makefile
index 0737101475c8..b3b1468f1a9d 100644
--- a/biology/ugene/Makefile
+++ b/biology/ugene/Makefile
@@ -1,17 +1,18 @@
-# Created by: Hannes Hauswedell <h2+fbsdports@fsfe.org>
-
PORTNAME= ugene
-PORTVERSION= 39.0
+PORTVERSION= 40.1
+PORTREVISION= 1
CATEGORIES= biology science
MAINTAINER= h2+fbsdports@fsfe.org
COMMENT= Integrated bioinformatics toolkit
+WWW= https://ugene.net/
LICENSE= GPLv2+
LICENSE_FILE= ${WRKSRC}/LICENSE.txt
-BROKEN_aarch64= Fails to build: invokes x86 asm
-BROKEN_riscv64= Fails to build: invokes x86 asm
+BROKEN_aarch64= fails to build: invokes x86 asm
+BROKEN_armv7= fails to build: src/SendReportDialog.cpp:435:20: error: invalid output constraint '=a' in asm, see https://github.com/ugeneunipro/ugene/issues/919
+BROKEN_riscv64= fails to build: invokes x86 asm
RUN_DEPENDS= bash:shells/bash
@@ -20,14 +21,14 @@ GH_ACCOUNT= ugeneunipro
USES= desktop-file-utils gl qmake qt:5 shared-mime-info sqlite xorg
USE_GL= gl glu
-USE_QT= buildtools_build linguisttools_build \
+USE_QT= buildtools:build linguisttools:build \
core gui network opengl printsupport scripttools script \
sql svg testlib widgets xml \
- imageformats_run
+ imageformats:run
USE_XORG= x11 xtst
QMAKE_ARGS= INSTALL_PREFIX="${PREFIX}" UGENE_INSTALL_DATA="${DATADIR}" \
- INSTALL_MANDIR="${MAN1PREFIX}/man" \
+ INSTALL_MANDIR="${PREFIX}/share/man" \
UGENE_LRELEASE="${LRELEASE}" UGENE_LUPDATE="${LUPDATE}" \
UGENE_USE_BUNDLED_SQLITE=0
ALL_TARGET= release
@@ -47,7 +48,7 @@ post-patch:
# yes, bash is required, stuff will not execute with sh
@${REINPLACE_CMD} -e 's|/bin/bash|/usr/bin/env bash|' \
${WRKSRC}/src/gen_bin_script.cmd \
- ${WRKSRC}/installer/_common_data/ugene
+ ${WRKSRC}/etc/shared/ugene ${WRKSRC}/etc/shared/ugened
@${REINPLACE_CMD} -e 's|-bit version|& for ${OPSYS}/${ARCH}|' \
${WRKSRC}/src/ugeneui/src/main_window/AboutDialogController.cpp
@${REINPLACE_CMD} 's, -lbreakpad$$$$D,,' \
@@ -55,13 +56,8 @@ post-patch:
${WRKSRC}/src/plugins_checker/plugins_checker.pri \
${WRKSRC}/src/ugenecl/ugenecl.pri \
${WRKSRC}/src/ugeneui/ugeneui.pri
- @${REINPLACE_CMD} -e '218,220s|NULL)|false)|' \
- ${WRKSRC}/src/plugins/GUITestBase/src/GTUtilsMdi.cpp
- @${REINPLACE_CMD} -e '/--no-pie/s,unix:!macx,linux-g++,' \
- ${WRKSRC}/src/plugins_checker/plugins_checker.pri \
- ${WRKSRC}/src/ugenecl/ugenecl.pri \
- ${WRKSRC}/src/ugenem/ugenem.pro \
- ${WRKSRC}/src/ugeneui/ugeneui.pri
+ @${REINPLACE_CMD} -e '/ugene\.desktop/s,share,&d,' \
+ ${WRKSRC}/ugene.pri
post-stage:
@cd ${STAGEDIR}${PREFIX} && ${RM} bin/ecp.* lib/ugene/ecp.*