aboutsummaryrefslogtreecommitdiff
path: root/cad/ldview/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'cad/ldview/Makefile')
-rw-r--r--cad/ldview/Makefile18
1 files changed, 12 insertions, 6 deletions
diff --git a/cad/ldview/Makefile b/cad/ldview/Makefile
index 8796d303ac42..fa1460c3c08a 100644
--- a/cad/ldview/Makefile
+++ b/cad/ldview/Makefile
@@ -1,10 +1,12 @@
PORTNAME= ldview
DISTVERSIONPREFIX= v
-DISTVERSION= 4.4
+DISTVERSION= 4.5
+PORTREVISION= 2
CATEGORIES= cad
MAINTAINER= yuri@FreeBSD.org
COMMENT= LDraw model viewer
+WWW= https://tcobbs.github.io/ldview/
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/../license.txt
@@ -18,21 +20,25 @@ RUN_DEPENDS= bash:shells/bash \
ldraw>0:cad/ldraw
USES= desktop-file-utils gl gmake jpeg qmake qt:5 shared-mime-info shebangfix xorg
-USE_QT= core gui linguist opengl printsupport widgets buildtools_build qmake_build
-USE_GL= gl glu
-USE_XORG= x11
-
USE_GITHUB= yes
GH_ACCOUNT= tcobbs
+USE_GL= gl glu
+USE_QT= core gui linguist opengl printsupport widgets buildtools:build qmake:build
+USE_XORG= x11
SHEBANG_FILES= desktop/ldraw-thumbnailer
+QMAKE_ARGS= CONFIG+=EXPORT_3DS
+
WRKSRC_SUBDIR= QT
-QMAKE_ARGS= MANDIR=${PREFIX}/man CONFIG+=EXPORT_3DS
+.include <bsd.port.options.mk>
post-patch:
@${REINPLACE_CMD} -e 's|"/usr/share/ldraw"|"${PREFIX}/share/ldraw"|' ${WRKSRC}/ModelViewerWidget.cpp
+.if ${OPSYS} == FreeBSD && ( ${OSVERSION} >= 1400091 || ( ${OSVERSION} >= 1302507 && ${OSVERSION} < 1400000 ))
+ @${REINPLACE_CMD} -e 's|register ||' ${WRKSRC}/../LDLoader/LDrawIni.c
+.endif
pre-configure:
@cd ${WRKSRC} && ${LRELEASE} LDView.pro