aboutsummaryrefslogtreecommitdiff
path: root/cad/netgen/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'cad/netgen/Makefile')
-rw-r--r--cad/netgen/Makefile16
1 files changed, 10 insertions, 6 deletions
diff --git a/cad/netgen/Makefile b/cad/netgen/Makefile
index 6edee31b0864..547751d3ba9f 100644
--- a/cad/netgen/Makefile
+++ b/cad/netgen/Makefile
@@ -1,18 +1,16 @@
-# Created by: Thierry Thomas <thierry@FreeBSD.org>
-
PORTNAME= netgen
-PORTVERSION= 6.2.2104
+PORTVERSION= 6.2.2402
DISTVERSIONPREFIX= v
CATEGORIES= cad
MAINTAINER= stephen@FreeBSD.org
COMMENT= Automatic 3D tetrahedral mesh generator
+WWW= https://ngsolve.org/
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/LICENSE
-ONLY_FOR_ARCHS= amd64 i386
-ONLY_FOR_ARCHS_REASON= relies on rdtsc() call and the TSC is specific to x86
+BROKEN_i386= compiler errors
BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pytest>=0:devel/py-pytest@${PY_FLAVOR} \
git:devel/git
@@ -21,7 +19,7 @@ USES= cmake python tcl tk gl xorg
USE_GITHUB= yes
GH_ACCOUNT= NGSolve
-GH_TUPLE= NGSolve:pybind11:v2.4.3:pybind11/external_dependencies/pybind11
+GH_TUPLE= NGSolve:pybind11:v2.11.1:pybind11/external_dependencies/pybind11
USE_GL= gl glu
USE_XORG= x11 xmu xi
@@ -31,6 +29,12 @@ CFLAGS+= -I${LOCALBASE}/include -I${TK_INCLUDEDIR}/generic -I${TK_INCLUDEDIR}/un
CXXFLAGS+= -I${LOCALBASE}/include -I${TK_INCLUDEDIR}/generic -I${TK_INCLUDEDIR}/unix
LDFLAGS+= -lexecinfo
+CMAKE_OFF= USE_NATIVE_ARCH
+
+CMAKE_ARGS+= -DUSE_OCC=OFF
+
+CONFLICTS_INSTALL= libvisual pybind11 # bin/netgen include/pybind11/attr.h lib/libvisual.so
+
OPTIONS_DEFINE= JPEG MPEG CGNS
JPEG_DESC= Enable snapshots using jpeg