aboutsummaryrefslogtreecommitdiff
path: root/chinese/libime-jyutping/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'chinese/libime-jyutping/Makefile')
-rw-r--r--chinese/libime-jyutping/Makefile31
1 files changed, 15 insertions, 16 deletions
diff --git a/chinese/libime-jyutping/Makefile b/chinese/libime-jyutping/Makefile
index 75bd7ae233a2..9e7302488837 100644
--- a/chinese/libime-jyutping/Makefile
+++ b/chinese/libime-jyutping/Makefile
@@ -1,39 +1,38 @@
-# Created by: Ka Ho Ng <khng300@gmail.com>
-
PORTNAME= libime-jyutping
-DISTVERSION= 1.0.2
+DISTVERSION= 1.0.6
+PORTREVISION= 5
CATEGORIES= chinese textproc
-MASTER_SITES= https://download.fcitx-im.org/data/:dict,model
-DISTFILES= ${DICT_TAR}:dict \
+MASTER_SITES= https://download.fcitx-im.org/fcitx5/${PORTNAME}/ \
+ https://download.fcitx-im.org/data/:dict,model
+DISTFILES= ${DISTNAME}${EXTRACT_SUFX} \
+ ${DICT_TAR}:dict \
${MODEL_TAR}:model
DIST_SUBDIR= ${PORTNAME}
EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX}
-MAINTAINER= khng300@gmail.com
+MAINTAINER= khng@FreeBSD.org
COMMENT= Library to support Jyutping through libime
+WWW= https://github.com/fcitx/libime-jyutping
-LICENSE= LGPL21+ GPLv3+
+LICENSE= GPLv3+ LGPL21+
LICENSE_COMB= multi
-BUILD_DEPENDS= ${LOCALBASE}/lib/fcitx5/punctuation.so:chinese/fcitx5-chinese-addons
+BUILD_DEPENDS= ${LOCALBASE}/lib/fcitx5/libpunctuation.so:chinese/fcitx5-chinese-addons
LIB_DEPENDS= libboost_iostreams.so:devel/boost-libs \
- libIMECore.so:chinese/libime \
- libFcitx5Core.so:textproc/fcitx5
-RUN_DEPENDS= ${LOCALBASE}/lib/fcitx5/punctuation.so:chinese/fcitx5-chinese-addons
+ libFcitx5Core.so:textproc/fcitx5 \
+ libIMECore.so:chinese/libime
+RUN_DEPENDS= ${LOCALBASE}/lib/fcitx5/libpunctuation.so:chinese/fcitx5-chinese-addons
-USES= compiler:c++17-lang cmake gettext-tools kde:5 localbase
+USES= cmake compiler:c++17-lang gettext-tools kde:5 localbase tar:xz
PLIST_SUB= VER=${PORTVERSION}
USE_LDCONFIG= yes
-USE_GITHUB= yes
-GH_ACCOUNT= fcitx
-
USE_KDE= ecm
CMAKE_ON= ENABLE_ENGINE
-CMAKE_OFF= ENABLE_TEST ENABLE_DOC
+CMAKE_OFF= ENABLE_DOC ENABLE_TEST
MAKE_ENV= FCITX5_DOWNLOAD_DISALLOWED=TRUE
# These must follow data/CMakeLists.txt