aboutsummaryrefslogtreecommitdiff
path: root/comms/freedv/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'comms/freedv/Makefile')
-rw-r--r--comms/freedv/Makefile23
1 files changed, 14 insertions, 9 deletions
diff --git a/comms/freedv/Makefile b/comms/freedv/Makefile
index 46e7dd66f92b..96802b2c9e04 100644
--- a/comms/freedv/Makefile
+++ b/comms/freedv/Makefile
@@ -1,28 +1,33 @@
PORTNAME= freedv
-DISTVERSION= 1.3.1
-PORTREVISION= 6
+DISTVERSIONPREFIX=v
+DISTVERSION= 1.7.0
+PORTREVISION= 2
CATEGORIES= comms hamradio
-MASTER_SITES= https://hobbes1069.fedorapeople.org/freetel/freedv/
MAINTAINER= hamradio@FreeBSD.org
COMMENT= Narrow band digital voice
+WWW= https://freedv.org/
LICENSE= LGPL21
LIB_DEPENDS= libcodec2.so:audio/codec2 \
libportaudio.so:audio/portaudio \
+ libgsm.so:audio/gsm \
libhamlib.so:comms/hamlib \
libsamplerate.so:audio/libsamplerate \
libsox.so:audio/sox \
libsndfile.so:audio/libsndfile \
libspeex.so:audio/speex \
- libspeexdsp.so:audio/speexdsp
+ libspeexdsp.so:audio/speexdsp \
+ liblpcnetfreedv.so:audio/lpcnet
-USES= cmake compiler:c++11-lib gnome tar:xz
-USE_WX= 3.0+
-CMAKE_ARGS+= -DCODEC2_INCLUDE_DIRS=${LOCALBASE}/include/codec2 \
- -DCODEC2_LIBRARY=${LOCALBASE}/lib/libcodec2.so \
- -DUSE_STATIC_CODEC2=FALSE \
+USES= cmake compiler:c++11-lib pkgconfig tar:xz
+USE_WX= 3.0+
+USE_GITHUB= yes
+GH_ACCOUNT= drowe67
+GH_PROJECT= freedv-gui
+
+CMAKE_ARGS= -DUSE_STATIC_CODEC2=FALSE \
-DUSE_STATIC_PORTAUDIO=FALSE \
-DUSE_STATIC_SOX=FALSE \
-DUSE_STATIC_SPEEXDSP=FALSE