aboutsummaryrefslogtreecommitdiff
path: root/comms/freedv/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'comms/freedv/Makefile')
-rw-r--r--comms/freedv/Makefile19
1 files changed, 11 insertions, 8 deletions
diff --git a/comms/freedv/Makefile b/comms/freedv/Makefile
index e6e5a4ea808b..2a66cf1203e9 100644
--- a/comms/freedv/Makefile
+++ b/comms/freedv/Makefile
@@ -1,27 +1,30 @@
PORTNAME= freedv
-DISTVERSION= 1.3.1
-PORTREVISION= 6
+DISTVERSIONPREFIX=v
+DISTVERSION= 1.7.0
CATEGORIES= comms hamradio
-MASTER_SITES= https://hobbes1069.fedorapeople.org/freetel/freedv/
MAINTAINER= hamradio@FreeBSD.org
COMMENT= Narrow band digital voice
LICENSE= LGPL21
-BROKEN= Needs update due to Hamlib changes
-
LIB_DEPENDS= libcodec2.so:audio/codec2 \
libportaudio.so:audio/portaudio \
+ libgsm.so:audio/gsm \
libhamlib.so:comms/hamlib \
libsamplerate.so:audio/libsamplerate \
libsox.so:audio/sox \
libsndfile.so:audio/libsndfile \
libspeex.so:audio/speex \
- libspeexdsp.so:audio/speexdsp
+ libspeexdsp.so:audio/speexdsp \
+ liblpcnetfreedv.so:audio/lpcnet
+
+USES= cmake compiler:c++11-lib tar:xz
+USE_WX= 3.0+
+USE_GITHUB= yes
+GH_ACCOUNT= drowe67
+GH_PROJECT= freedv-gui
-USES= cmake compiler:c++11-lib gnome tar:xz
-USE_WX= 3.0+
CMAKE_ARGS+= -DCODEC2_INCLUDE_DIRS=${LOCALBASE}/include/codec2 \
-DCODEC2_LIBRARY=${LOCALBASE}/lib/libcodec2.so \
-DUSE_STATIC_CODEC2=FALSE \