aboutsummaryrefslogtreecommitdiff
path: root/comms/qrq/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'comms/qrq/Makefile')
-rw-r--r--comms/qrq/Makefile16
1 files changed, 12 insertions, 4 deletions
diff --git a/comms/qrq/Makefile b/comms/qrq/Makefile
index 3654374d476d..dbe4171369f9 100644
--- a/comms/qrq/Makefile
+++ b/comms/qrq/Makefile
@@ -1,10 +1,12 @@
PORTNAME= qrq
-PORTVERSION= 0.3.3
+PORTVERSION= 0.3.4
+PORTREVISION= 1
CATEGORIES= comms hamradio
MASTER_SITES= http://fkurz.net/ham/qrq/
MAINTAINER= hamradio@FreeBSD.org
COMMENT= Morse telegraphy trainer similar to the classic DOS version by DL4MM
+WWW= https://fkurz.net/ham/qrq.html
LICENSE= GPLv2
@@ -13,9 +15,15 @@ USE_CSTD= c99
SHEBANG_FILES= qrqscore
-post-install:
- ${INSTALL_DATA} ${WRKSRC}/qrq.png ${STAGEDIR}${DATADIR}/qrq.png
+post-patch:
+ @${REINPLACE_CMD} -e 's|%%LOCALBASE%%|${LOCALBASE}|g' \
+ -e 's|%%PREFIX%%|${PREFIX}|g' \
+ ${WRKSRC}/Makefile
+ @${REINPLACE_CMD} -e 's|%%PREFIX%%|${PREFIX}|g' \
+ ${WRKSRC}/qrq.c
-MAKE_ENV= DESTDIR=${LOCALBASE}
+post-install:
+ ${MKDIR} ${STAGEDIR}${DATADIR}
+ ${INSTALL_DATA} ${WRKSRC}/qrq.png ${STAGEDIR}${DATADIR}
.include <bsd.port.mk>